summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-03-06 10:31:01 +0100
committerRemi Collet <remi@php.net>2024-03-06 10:31:01 +0100
commitace2a8a2363be8901a40d2bfc8a83204e96a0f42 (patch)
tree3c09816d2a4d9ec5b4fbf6d5800b9364be4267b0
parentd2d1bc5320f5409ea3cf8aac21b4c4505b144c7a (diff)
improve --check-version for RPM
-rw-r--r--phpunit11-rpm.patch42
-rw-r--r--phpunit11.spec5
2 files changed, 39 insertions, 8 deletions
diff --git a/phpunit11-rpm.patch b/phpunit11-rpm.patch
index a4e43ed..b8e069b 100644
--- a/phpunit11-rpm.patch
+++ b/phpunit11-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2024-01-15 07:31:36.850034357 +0100
-+++ ./phpunit 2024-01-15 07:33:02.306130486 +0100
+--- ./phpunit.rpm 2024-03-01 07:19:34.000000000 +0100
++++ ./phpunit 2024-03-06 10:27:50.097810154 +0100
@@ -46,27 +46,13 @@ if (isset($GLOBALS['_composer_autoload_p
define('PHPUNIT_COMPOSER_INSTALL', $GLOBALS['_composer_autoload_path']);
@@ -49,10 +49,38 @@ diff -up ./phpunit.rpm ./phpunit
+ // PHPUnit v6 to v9
+ PHPUnit\TextUI\Command::main();
+}
+diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/Command/Commands/VersionCheckCommand.php
+--- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-03-06 10:27:59.407166291 +0100
++++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-03-06 10:28:47.312998973 +0100
+@@ -24,7 +24,7 @@ final readonly class VersionCheckCommand
+ public function execute(): Result
+ {
+ $latestVersion = file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit');
+- $latestCompatibleVersion = @file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit-' . Version::majorVersionNumber());
++ $latestCompatibleVersion = @file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit-' . $major=Version::majorVersionNumber());
+
+ $notLatest = version_compare($latestVersion, Version::id(), '>');
+ $notLatestCompatible = false;
+@@ -47,6 +47,7 @@ final readonly class VersionCheckCommand
+ Version::id(),
+ $latestCompatibleVersion,
+ );
++ $buffer .= sprintf('Try a system update for new phpunit%s package.' . PHP_EOL, $major);
+ }
+
+ if ($notLatest) {
+@@ -54,6 +55,7 @@ final readonly class VersionCheckCommand
+ 'The latest version is PHPUnit %s.' . PHP_EOL,
+ $latestVersion,
+ );
++ $buffer .= sprintf('Try to install and use the phpunit%s command.' . PHP_EOL, explode('.', $latestVersion)[0]);
+ }
+
+ return Result::from($buffer, Result::FAILURE);
diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Configuration/Xml/SchemaFinder.php
---- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-01-15 07:25:40.000000000 +0100
-+++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-01-15 07:31:36.850034357 +0100
-@@ -48,6 +48,6 @@ final class SchemaFinder
+--- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-03-01 07:19:34.000000000 +0100
++++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-03-06 10:27:50.097810154 +0100
+@@ -75,6 +75,6 @@ final readonly class SchemaFinder
return __PHPUNIT_PHAR_ROOT__ . '/';
}
@@ -61,8 +89,8 @@ diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Config
}
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2024-01-15 07:25:39.000000000 +0100
-+++ ./tests/bootstrap.php 2024-01-15 07:31:36.851034393 +0100
+--- ./tests/bootstrap.php.rpm 2024-03-01 07:19:34.000000000 +0100
++++ ./tests/bootstrap.php 2024-03-06 10:27:50.097810154 +0100
@@ -11,8 +11,8 @@ if (!defined('TEST_FILES_PATH')) {
define('TEST_FILES_PATH', __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR);
}
diff --git a/phpunit11.spec b/phpunit11.spec
index 2e74eb6..0bb648e 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -39,7 +39,7 @@
Name: %{pk_project}%{ver_major}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: The PHP Unit Testing framework version %{ver_major}
License: BSD-3-Clause
@@ -312,6 +312,9 @@ exit $ret
%changelog
+* Wed Mar 6 2024 Remi Collet <remi@remirepo.net> - 11.0.4-2
+- improve --check-version for RPM
+
* Fri Mar 1 2024 Remi Collet <remi@remirepo.net> - 11.0.4-1
- update to 11.0.4