summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-03-22 07:30:50 +0100
committerRemi Collet <remi@php.net>2024-03-22 07:30:50 +0100
commit0f75f7c74f1f3df8b850433b20d3f641070ec918 (patch)
tree448cf0c3274de9a693277994f84b6e65a22097b0
parent28c4a5366b4c54489d518f81db16a9a3190963f0 (diff)
update to 11.0.8
-rw-r--r--phpunit11-rpm.patch29
-rw-r--r--phpunit11.spec9
2 files changed, 25 insertions, 13 deletions
diff --git a/phpunit11-rpm.patch b/phpunit11-rpm.patch
index ec83474..d117536 100644
--- a/phpunit11-rpm.patch
+++ b/phpunit11-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2024-03-01 07:19:34.000000000 +0100
-+++ ./phpunit 2024-03-06 10:27:50.097810154 +0100
+--- ./phpunit.rpm 2024-03-21 10:23:39.000000000 +0100
++++ ./phpunit 2024-03-21 14:04:08.699638712 +0100
@@ -46,27 +46,13 @@ if (isset($GLOBALS['_composer_autoload_p
define('PHPUNIT_COMPOSER_INSTALL', $GLOBALS['_composer_autoload_path']);
@@ -50,8 +50,8 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main();
+}
diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/Command/Commands/VersionCheckCommand.php
---- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-03-06 10:27:59.407166291 +0100
-+++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-03-06 10:28:47.312998973 +0100
+--- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-03-21 10:23:39.000000000 +0100
++++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-03-21 14:04:31.164578940 +0100
@@ -24,7 +24,7 @@ final readonly class VersionCheckCommand
public function execute(): Result
{
@@ -61,11 +61,20 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
$notLatest = version_compare($latestVersion, Version::id(), '>');
$notLatestCompatible = false;
+@@ -39,7 +39,7 @@ final readonly class VersionCheckCommand
+ );
+ }
+
+- $buffer = 'You are not using the latest version of PHPUnit.' . PHP_EOL;
++ $buffer = 'You are not using the latest version of PHPUnit.' . PHP_EOL . PHP_EOL;
+
+ if ($notLatestCompatible) {
+ $buffer .= sprintf(
@@ -47,6 +47,7 @@ final readonly class VersionCheckCommand
Version::id(),
$latestCompatibleVersion,
);
-+ $buffer .= sprintf('Try a system update for new phpunit%s package.' . PHP_EOL, $major);
++ $buffer .= sprintf('Try a system update for new phpunit%s package.' . PHP_EOL . PHP_EOL, $major);
}
if ($notLatest) {
@@ -74,14 +83,14 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
$latestVersion,
);
+ if ($major !== ($new = (int)explode('.', $latestVersion)[0])) {
-+ $buffer .= sprintf('Try to install and use the phpunit%d command.' . PHP_EOL, $new);
++ $buffer .= sprintf('Try to install and use the phpunit%d command.' . PHP_EOL . PHP_EOL, $new);
+ }
}
return Result::from($buffer, Result::FAILURE);
diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Configuration/Xml/SchemaFinder.php
---- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-03-01 07:19:34.000000000 +0100
-+++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-03-06 10:27:50.097810154 +0100
+--- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-03-21 10:23:39.000000000 +0100
++++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-03-21 14:04:08.699638712 +0100
@@ -75,6 +75,6 @@ final readonly class SchemaFinder
return __PHPUNIT_PHAR_ROOT__ . '/';
}
@@ -91,8 +100,8 @@ diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Config
}
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2024-03-01 07:19:34.000000000 +0100
-+++ ./tests/bootstrap.php 2024-03-06 10:27:50.097810154 +0100
+--- ./tests/bootstrap.php.rpm 2024-03-21 10:23:39.000000000 +0100
++++ ./tests/bootstrap.php 2024-03-21 14:04:08.699638712 +0100
@@ -11,8 +11,8 @@ if (!defined('TEST_FILES_PATH')) {
define('TEST_FILES_PATH', __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR);
}
diff --git a/phpunit11.spec b/phpunit11.spec
index 1dcdd35..d126bc1 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit afa8d61ba7ae78da739938c999140eb767a1ad7f
-%global gh_date 2024-03-21
+%global gh_commit 48ea58408879a9aad630022186398364051482fc
+%global gh_date 2024-03-22
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 11
%global ver_minor 0
-%global upstream_version 11.0.7
+%global upstream_version 11.0.8
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -313,6 +313,9 @@ exit $ret
%changelog
+* Fri Mar 22 2024 Remi Collet <remi@remirepo.net> - 11.0.8-1
+- update to 11.0.8
+
* Thu Mar 21 2024 Remi Collet <remi@remirepo.net> - 11.0.7-1
- update to 11.0.7