summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json3
-rw-r--r--phpunit10-rpm.patch3
-rw-r--r--phpunit10.spec14
3 files changed, 11 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index ca3cc15..96e30b6 100644
--- a/composer.json
+++ b/composer.json
@@ -77,13 +77,14 @@
"files": [
"tests/_files/CoverageNamespacedFunctionTest.php",
"tests/_files/CoveredFunction.php",
+ "tests/_files/Generator.php",
"tests/_files/NamespaceCoveredFunction.php",
"tests/end-to-end/code-coverage/ignore-function-using-attribute/src/CoveredFunction.php"
]
},
"extra": {
"branch-alias": {
- "dev-main": "10.2-dev"
+ "dev-main": "10.3-dev"
}
}
}
diff --git a/phpunit10-rpm.patch b/phpunit10-rpm.patch
index f4f7c81..2e82286 100644
--- a/phpunit10-rpm.patch
+++ b/phpunit10-rpm.patch
@@ -72,7 +72,7 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
if ($composer && $phar) {
print 'More than one test fixture autoloader is available, exiting.' . PHP_EOL;
-@@ -28,10 +28,14 @@ if (!$composer && !$phar) {
+@@ -28,10 +28,15 @@ if (!$composer && !$phar) {
if ($composer) {
if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
@@ -84,6 +84,7 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
+ require_once PHPUNIT_COMPOSER_INSTALL;
+ require_once __DIR__ . '/_files/CoverageNamespacedFunctionTest.php';
+ require_once __DIR__ . '/_files/CoveredFunction.php';
++ require_once __DIR__ . '/_files/Generator.php';
+ require_once __DIR__ . '/_files/NamespaceCoveredFunction.php';
+ require_once __DIR__ . '/autoload.php';
}
diff --git a/phpunit10.spec b/phpunit10.spec
index 42a5cdd..20e5ebe 100644
--- a/phpunit10.spec
+++ b/phpunit10.spec
@@ -8,15 +8,12 @@
# Please, preserve the changelog entries
#
-# remirepo:4
-%if "%{?vendeur}" == "remi"
-# For compatibility with SCL
+# remirepo:1
%undefine __brp_mangle_shebangs
-%endif
%bcond_without tests
-%global gh_commit a215d9ee8bac1733796e4ddff3306811f14414e5
+%global gh_commit c87ae282d17b256d09cfef0eb4f5db2d09cfd36a
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -28,9 +25,9 @@
%global ns_vendor PHPUnit10
%global php_home %{_datadir}/php
%global ver_major 10
-%global ver_minor 2
+%global ver_minor 3
-%global upstream_version 10.2.7
+%global upstream_version 10.3.0
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -304,6 +301,9 @@ exit $ret
%changelog
+* Fri Aug 4 2023 Remi Collet <remi@remirepo.net> - 10.3.0-1
+- update to 10.3.0
+
* Wed Aug 2 2023 Remi Collet <remi@remirepo.net> - 10.2.7-1
- update to 10.2.7
- raise dependency on sebastian/global-state 6.0.1