summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phpunit10.spec19
2 files changed, 14 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 396e0af..708d821 100644
--- a/composer.json
+++ b/composer.json
@@ -39,7 +39,7 @@
"phpunit/php-timer": "^6.0.0",
"sebastian/cli-parser": "^2.0.1",
"sebastian/code-unit": "^2.0.0",
- "sebastian/comparator": "^5.0.1",
+ "sebastian/comparator": "^5.0.2",
"sebastian/diff": "^5.1.1",
"sebastian/environment": "^6.1.0",
"sebastian/exporter": "^5.1.2",
diff --git a/phpunit10.spec b/phpunit10.spec
index f58bb87..0aa4b53 100644
--- a/phpunit10.spec
+++ b/phpunit10.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit ff7fb85cdf88131b83e721fb2a327b664dbed275
-%global gh_date 2024-07-18
+%global gh_commit b15524febac0153876b4ba9aab3326c2ee94c897
+%global gh_date 2024-08-13
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 10
%global ver_minor 5
-%global upstream_version 10.5.28
+%global upstream_version 10.5.30
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -63,7 +63,7 @@ BuildRequires: (php-composer(phpunit/php-text-template) >= 3.0.1 with php-c
BuildRequires: (php-composer(phpunit/php-timer) >= 6.0 with php-composer(phpunit/php-timer) < 7)
BuildRequires: (php-composer(sebastian/cli-parser) >= 2.0.1 with php-composer(sebastian/cli-parser) < 3)
BuildRequires: (php-composer(sebastian/code-unit) >= 2.0 with php-composer(sebastian/code-unit) < 3)
-BuildRequires: (php-composer(sebastian/comparator) >= 5.0.1 with php-composer(sebastian/comparator) < 6)
+BuildRequires: (php-composer(sebastian/comparator) >= 5.0.2 with php-composer(sebastian/comparator) < 6)
BuildRequires: (php-composer(sebastian/diff) >= 5.1.1 with php-composer(sebastian/diff) < 6)
BuildRequires: (php-composer(sebastian/environment) >= 6.1.0 with php-composer(sebastian/environment) < 7)
BuildRequires: (php-composer(sebastian/exporter) >= 5.1.2 with php-composer(sebastian/exporter) < 6)
@@ -99,7 +99,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "phpunit/php-timer": "^6.0.0",
# "sebastian/cli-parser": "^2.0.1",
# "sebastian/code-unit": "^2.0.0",
-# "sebastian/comparator": "^5.0.1",
+# "sebastian/comparator": "^5.0.2",
# "sebastian/diff": "^5.1.1",
# "sebastian/environment": "^6.1.0",
# "sebastian/exporter": "^5.1.2",
@@ -126,7 +126,7 @@ Requires: (php-composer(phpunit/php-text-template) >= 3.0.1 with php-c
Requires: (php-composer(phpunit/php-timer) >= 6.0 with php-composer(phpunit/php-timer) < 7)
Requires: (php-composer(sebastian/cli-parser) >= 2.0.1 with php-composer(sebastian/cli-parser) < 3)
Requires: (php-composer(sebastian/code-unit) >= 2.0 with php-composer(sebastian/code-unit) < 3)
-Requires: (php-composer(sebastian/comparator) >= 5.0.1 with php-composer(sebastian/comparator) < 6)
+Requires: (php-composer(sebastian/comparator) >= 5.0.2 with php-composer(sebastian/comparator) < 6)
Requires: (php-composer(sebastian/diff) >= 5.1.1 with php-composer(sebastian/diff) < 6)
Requires: (php-composer(sebastian/environment) >= 6.1.0 with php-composer(sebastian/environment) < 7)
Requires: (php-composer(sebastian/exporter) >= 5.1.2 with php-composer(sebastian/exporter) < 6)
@@ -273,6 +273,13 @@ exit $ret
%changelog
+* Tue Aug 13 2024 Remi Collet <remi@remirepo.net> - 10.5.30-1
+- update to 10.5.30
+- raise dependency on sebastian/comparator 5.0.2
+
+* Tue Jul 30 2024 Remi Collet <remi@remirepo.net> - 10.5.29-1
+- update to 10.5.29
+
* Fri Jul 19 2024 Remi Collet <remi@remirepo.net> - 10.5.28-1
- update to 10.5.28