summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phpunit10-rpm.patch21
-rw-r--r--phpunit10.spec66
3 files changed, 66 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index a9578dc..bc1f73c 100644
--- a/composer.json
+++ b/composer.json
@@ -29,7 +29,7 @@
"ext-mbstring": "*",
"ext-xml": "*",
"ext-xmlwriter": "*",
- "myclabs/deep-copy": "^1.12.0",
+ "myclabs/deep-copy": "^1.12.1",
"phar-io/manifest": "^2.0.4",
"phar-io/version": "^3.2.1",
"phpunit/php-code-coverage": "^10.1.16",
diff --git a/phpunit10-rpm.patch b/phpunit10-rpm.patch
index 0f7b1d0..0b4ef15 100644
--- a/phpunit10-rpm.patch
+++ b/phpunit10-rpm.patch
@@ -51,7 +51,7 @@ diff -up ./phpunit.rpm ./phpunit
+}
diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/Command/Commands/VersionCheckCommand.php
--- ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm 2024-10-28 16:44:45.000000000 +0100
-+++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-10-28 16:49:46.388400560 +0100
++++ ./src/TextUI/Command/Commands/VersionCheckCommand.php 2024-10-28 17:08:20.070934441 +0100
@@ -39,7 +39,7 @@ final class VersionCheckCommand implemen
assert($latestVersion !== false);
@@ -61,7 +61,12 @@ diff -up ./src/TextUI/Command/Commands/VersionCheckCommand.php.rpm ./src/TextUI/
assert($latestCompatibleVersion !== false);
-@@ -52,7 +52,7 @@ final class VersionCheckCommand implemen
+@@ -48,11 +48,11 @@ final class VersionCheckCommand implemen
+
+ if (!$notLatest && !$notLatestCompatible) {
+ return Result::from(
+- 'You are using the latest version of PHPUnit.' . PHP_EOL,
++ 'You are using the latest version of PHPUnit.' . PHP_EOL . PHP_EOL,
);
}
@@ -133,8 +138,16 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
if ($phar) {
diff -up ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php
--- ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php.rpm 2024-10-28 16:44:45.000000000 +0100
-+++ ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php 2024-10-28 16:48:35.645635304 +0100
-@@ -35,8 +35,9 @@ final class VersionCheckCommandTest exte
++++ ./tests/unit/TextUI/Command/Commands/VersionCheckCommandTest.php 2024-10-28 17:05:46.654936571 +0100
+@@ -28,15 +28,16 @@ final class VersionCheckCommandTest exte
+ {
+ return [
+ [
+- 'You are using the latest version of PHPUnit.' . PHP_EOL,
++ 'You are using the latest version of PHPUnit.' . PHP_EOL . PHP_EOL,
+ 10,
+ '10.5.0',
+ '10.5.0',
'10.5.0',
],
[
diff --git a/phpunit10.spec b/phpunit10.spec
index 252cc98..d43708a 100644
--- a/phpunit10.spec
+++ b/phpunit10.spec
@@ -1,9 +1,8 @@
# remirepo/fedora spec file for phpunit10
#
-# Copyright (c) 2010-2024 Remi Collet
-#
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2010-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -14,14 +13,14 @@
%bcond_without tests
-%if 0%{?fedora} == 39
+%if 0%{?fedora} == 39 || 0%{?fedora} == 40
%bcond_without defcmd
%else
%bcond_with defcmd
%endif
-%global gh_commit a86773b9e887a67bc53efa9da9ad6e3f2498c132
-%global gh_date 2024-10-28
+%global gh_commit bd68a781d8e30348bc297449f5234b3458267ae8
+%global gh_date 2025-02-07
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +33,7 @@
%global ver_major 10
%global ver_minor 5
-%global upstream_version 10.5.38
+%global upstream_version 10.5.45
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -53,7 +52,7 @@ Patch0: %{name}-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 8.1
-BuildRequires: (php-composer(myclabs/deep-copy) >= 1.12.0 with php-composer(myclabs/deep-copy) < 2)
+BuildRequires: (php-composer(myclabs/deep-copy) >= 1.12.1 with php-composer(myclabs/deep-copy) < 2)
BuildRequires: (php-composer(phar-io/manifest) >= 2.0.4 with php-composer(phar-io/manifest) < 3)
BuildRequires: (php-composer(phar-io/version) >= 3.2.1 with php-composer(phar-io/version) < 4)
BuildRequires: (php-composer(phpunit/php-code-coverage) >= 10.1.15 with php-composer(phpunit/php-code-coverage) < 11)
@@ -89,7 +88,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "ext-mbstring": "*",
# "ext-xml": "*",
# "ext-xmlwriter": "*",
-# "myclabs/deep-copy": "^1.12.0",
+# "myclabs/deep-copy": "^1.12.1",
# "phar-io/manifest": "^2.0.4",
# "phar-io/version": "^3.2.1",
# "phpunit/php-code-coverage": "^10.1.15",
@@ -116,7 +115,7 @@ Requires: php-libxml
Requires: php-mbstring
Requires: php-xml
Requires: php-xmlwriter
-Requires: (php-composer(myclabs/deep-copy) >= 1.12.0 with php-composer(myclabs/deep-copy) < 2)
+Requires: (php-composer(myclabs/deep-copy) >= 1.12.1 with php-composer(myclabs/deep-copy) < 2)
Requires: (php-composer(phar-io/manifest) >= 2.0.4 with php-composer(phar-io/manifest) < 3)
Requires: (php-composer(phar-io/version) >= 3.2.1 with php-composer(phar-io/version) < 4)
Requires: (php-composer(phpunit/php-code-coverage) >= 10.1.15 with php-composer(phpunit/php-code-coverage) < 11)
@@ -139,19 +138,23 @@ Requires: (php-composer(sebastian/version) >= 4.0.1 with php-c
# "ext-soap": "*",
Suggests: php-soap
# recommends latest versions
-# Fedora 38+ only until 8.1 EOL
-%if 0%{?fedora} >= 38
+# remirepo:2
+# Fedora 38+ only for 8.2
+%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
Recommends: phpunit11
+# remirepo:3
+%endif
+# Fedora 40+ only for 8.3
+%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
+Recommends: phpunit12
+# remirepo:1
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 10.0.0
-Requires: php-reflection
Requires: php-openssl
Requires: php-pcntl
-Requires: php-pcre
Requires: php-phar
-Requires: php-spl
%if 0%{?fedora} >= 39 || 0%{?rhel} >= 10
Provides: php-composer(phpunit/phpunit) = %{version}
@@ -173,7 +176,7 @@ Documentation: https://phpunit.readthedocs.io/
%setup -q -n %{gh_project}-%{gh_commit}
%patch -P0 -p0 -b .rpm
-#find . -name \*.rpm -delete -print
+find . -name \*.rpm -delete -print
%build
@@ -274,7 +277,34 @@ exit $ret
%changelog
-* Mon Oct 28 2024 Remi Collet <remi@remirepo.net> - 10.5.38-1
+* Fri Feb 7 2025 Remi Collet <remi@remirepo.net> - 10.5.45-1
+- update to 10.5.45
+
+* Mon Feb 3 2025 Remi Collet <remi@remirepo.net> - 11.5.6-2
+- F-40: add phpunit command, removed from phpunit11
+- recommend phpunit11 and phpunit12
+
+* Fri Jan 31 2025 Remi Collet <remi@remirepo.net> - 10.5.44-1
+- update to 10.5.44
+
+* Wed Jan 29 2025 Remi Collet <remi@remirepo.net> - 10.5.43-1
+- update to 10.5.43
+
+* Wed Jan 29 2025 Remi Collet <remi@remirepo.net> - 10.5.42-1
+- update to 10.5.42
+
+* Mon Jan 13 2025 Remi Collet <remi@remirepo.net> - 10.5.41-1
+- update to 10.5.41
+
+* Sun Dec 22 2024 Remi Collet <remi@remirepo.net> - 10.5.40-1
+- update to 10.5.40
+
+* Wed Dec 11 2024 Remi Collet <remi@remirepo.net> - 10.5.39-1
+- update to 10.5.39
+- raise dependency on myclabs/deep-copy 1.12.1
+- re-license spec file to CECILL-2.1
+
+* Mon Oct 28 2024 Remi Collet <remi@remirepo.net> - 10.5.38-2
- update to 10.5.38
* Mon Oct 21 2024 Remi Collet <remi@remirepo.net> - 10.5.37-1