summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-23 07:52:22 +0100
committerRemi Collet <remi@php.net>2024-01-23 07:52:22 +0100
commitf69a4438d8d65e9c6c614cee1f412fad3dc17f13 (patch)
tree6d3ac952fff1cfcce5906f2f369d5f7b5713e6cd
parent69cdb92347cbc932d2dcb69ba7aa8b0eeba90d5e (diff)
update to 10.5.9
-rwxr-xr-xmakesrc.sh4
-rw-r--r--phpunit10.spec9
2 files changed, 9 insertions, 4 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 2b84cb1..45fea74 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -8,6 +8,8 @@ VERSION=$(sed -n '/^%global upstream_version/{s/.* //;p}' $NAME.spec)
COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
SHORT=${COMMIT:0:7}
+DATE=$(date -d "$DATE -4 days" +%Y-%m-%d)
+
if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
echo "$NAME-$VERSION-$SHORT.tgz already there"
else
@@ -15,7 +17,7 @@ else
echo "Cloning..."
rm -rf $PROJECT-$COMMIT
- git clone --jobs 8 https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
+ git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
echo "Getting commit..."
pushd $PROJECT-$COMMIT
diff --git a/phpunit10.spec b/phpunit10.spec
index 9fc4343..0f875fe 100644
--- a/phpunit10.spec
+++ b/phpunit10.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit 08f4fa74d5fbfff1ef22abffee47aaedcaea227e
-%global gh_date 2024-01-19
+%global gh_commit 0bd663704f0165c9e76fe4f06ffa6a1ca727fdbe
+%global gh_date 2024-01-22
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 10
%global ver_minor 5
-%global upstream_version 10.5.8
+%global upstream_version 10.5.9
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -319,6 +319,9 @@ exit $ret
%changelog
+* Tue Jan 23 2024 Remi Collet <remi@remirepo.net> - 10.5.9-1
+- update to 10.5.9
+
* Fri Jan 19 2024 Remi Collet <remi@remirepo.net> - 10.5.8-1
- update to 10.5.8