summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-04-14 10:59:40 +0200
committerRemi Collet <remi@php.net>2023-04-14 10:59:40 +0200
commite922cedc49dddb6b9da49e758be057c14c31cde2 (patch)
tree8d211142c547ba00aa3f509062003973ae07841d
parentfd5c418c10739383973fb1cc35c4ec00ab0ec742 (diff)
update to 10.1.0
raise dependency on phpunit/php-code-coverage 10.1
-rw-r--r--composer.json7
-rw-r--r--phpunit10-rpm.patch20
-rw-r--r--phpunit10.spec22
3 files changed, 28 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 4c0ca2a..e825baa 100644
--- a/composer.json
+++ b/composer.json
@@ -32,7 +32,7 @@
"myclabs/deep-copy": "^1.10.1",
"phar-io/manifest": "^2.0.3",
"phar-io/version": "^3.0.2",
- "phpunit/php-code-coverage": "^10.0",
+ "phpunit/php-code-coverage": "^10.1",
"phpunit/php-file-iterator": "^4.0",
"phpunit/php-invoker": "^4.0",
"phpunit/php-text-template": "^3.0",
@@ -77,12 +77,13 @@
"files": [
"tests/_files/CoverageNamespacedFunctionTest.php",
"tests/_files/CoveredFunction.php",
- "tests/_files/NamespaceCoveredFunction.php"
+ "tests/_files/NamespaceCoveredFunction.php",
+ "tests/end-to-end/code-coverage/ignore-function-using-attribute/src/CoveredFunction.php"
]
},
"extra": {
"branch-alias": {
- "dev-main": "10.0-dev"
+ "dev-main": "10.1-dev"
}
}
}
diff --git a/phpunit10-rpm.patch b/phpunit10-rpm.patch
index 1ce77f1..f4f7c81 100644
--- a/phpunit10-rpm.patch
+++ b/phpunit10-rpm.patch
@@ -1,7 +1,7 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2023-02-03 16:32:47.889941148 +0100
-+++ ./phpunit 2023-02-03 16:41:15.850841011 +0100
-@@ -62,29 +62,25 @@ if (isset($GLOBALS['_composer_autoload_p
+--- ./phpunit.rpm 2023-04-14 10:47:29.000000000 +0200
++++ ./phpunit 2023-04-14 10:49:23.217236377 +0200
+@@ -71,29 +71,25 @@ if (isset($GLOBALS['_composer_autoload_p
define('PHPUNIT_COMPOSER_INSTALL', $GLOBALS['_composer_autoload_path']);
unset($GLOBALS['_composer_autoload_path']);
@@ -47,20 +47,20 @@ diff -up ./phpunit.rpm ./phpunit
+ // PHPUnit v6 to v9
+ PHPUnit\TextUI\Command::main();
+}
-diff -up ./src/Util/Xml/SchemaFinder.php.rpm ./src/Util/Xml/SchemaFinder.php
---- ./src/Util/Xml/SchemaFinder.php.rpm 2023-02-03 10:51:19.000000000 +0100
-+++ ./src/Util/Xml/SchemaFinder.php 2023-02-03 16:32:47.889941148 +0100
+diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Configuration/Xml/SchemaFinder.php
+--- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2023-04-14 10:51:13.796036447 +0200
++++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2023-04-14 10:53:03.227838557 +0200
@@ -48,6 +48,6 @@ final class SchemaFinder
return __PHPUNIT_PHAR_ROOT__ . '/';
}
-- return __DIR__ . '/../../../';
-+ return __DIR__ . '/../../';
+- return __DIR__ . '/../../../../';
++ return __DIR__ . '/../../../';
}
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2023-02-03 10:51:19.000000000 +0100
-+++ ./tests/bootstrap.php 2023-02-03 16:42:03.557642693 +0100
+--- ./tests/bootstrap.php.rpm 2023-04-14 10:47:29.000000000 +0200
++++ ./tests/bootstrap.php 2023-04-14 10:49:23.217236377 +0200
@@ -11,8 +11,8 @@ if (!defined('TEST_FILES_PATH')) {
define('TEST_FILES_PATH', __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR);
}
diff --git a/phpunit10.spec b/phpunit10.spec
index a68be37..0c2fe43 100644
--- a/phpunit10.spec
+++ b/phpunit10.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 20c23e85c86e5c06d63538ba464e8054f4744e62
+%global gh_commit 5a477aea03e61329132935689ae2d73f418f5e25
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -23,9 +23,9 @@
%global ns_vendor PHPUnit10
%global php_home %{_datadir}/php
%global ver_major 10
-%global ver_minor 0
+%global ver_minor 1
-%global upstream_version 10.0.19
+%global upstream_version 10.1.0
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -49,7 +49,7 @@ BuildRequires: (php-composer(doctrine/instantiator) >= 1.3.1 with php-c
BuildRequires: (php-composer(myclabs/deep-copy) >= 1.10.1 with php-composer(myclabs/deep-copy) < 2)
BuildRequires: (php-composer(phar-io/manifest) >= 2.0.3 with php-composer(phar-io/manifest) < 3)
BuildRequires: (php-composer(phar-io/version) >= 3.0.2 with php-composer(phar-io/version) < 4)
-BuildRequires: (php-composer(phpunit/php-code-coverage) >= 10.0 with php-composer(phpunit/php-code-coverage) < 11)
+BuildRequires: (php-composer(phpunit/php-code-coverage) >= 10.1 with php-composer(phpunit/php-code-coverage) < 11)
BuildRequires: (php-composer(phpunit/php-file-iterator) >= 4.0 with php-composer(phpunit/php-file-iterator) < 5)
BuildRequires: (php-composer(phpunit/php-invoker) >= 4.0 with php-composer(phpunit/php-invoker) < 5)
BuildRequires: (php-composer(phpunit/php-text-template) >= 3.0 with php-composer(phpunit/php-text-template) < 4)
@@ -70,7 +70,7 @@ BuildRequires: (php-composer(sebastian/version) >= 4.0 with php-c
BuildRequires: php-myclabs-deep-copy >= 1.10.1
BuildRequires: php-phar-io-manifest2 >= 2.0.3
BuildRequires: php-phar-io-version3 >= 3.0.2
-BuildRequires: php-phpunit-php-code-coverage10
+BuildRequires: php-phpunit-php-code-coverage10 >= 10.1
BuildRequires: php-phpunit-php-file-iterator4
BuildRequires: php-phpunit-php-invoker4
BuildRequires: php-phpunit-php-text-template3
@@ -107,7 +107,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "myclabs/deep-copy": "^1.10.1",
# "phar-io/manifest": "^2.0.3",
# "phar-io/version": "^3.0.2",
-# "phpunit/php-code-coverage": "^10.0",
+# "phpunit/php-code-coverage": "^10.1",
# "phpunit/php-file-iterator": "^4.0",
# "phpunit/php-invoker": "^4.0",
# "phpunit/php-text-template": "^3.0",
@@ -136,7 +136,7 @@ Requires: php-xmlwriter
Requires: (php-composer(myclabs/deep-copy) >= 1.10.1 with php-composer(myclabs/deep-copy) < 2)
Requires: (php-composer(phar-io/manifest) >= 2.0.3 with php-composer(phar-io/manifest) < 3)
Requires: (php-composer(phar-io/version) >= 3.0.2 with php-composer(phar-io/version) < 4)
-Requires: (php-composer(phpunit/php-code-coverage) >= 10.0 with php-composer(phpunit/php-code-coverage) < 11)
+Requires: (php-composer(phpunit/php-code-coverage) >= 10.1 with php-composer(phpunit/php-code-coverage) < 11)
Requires: (php-composer(phpunit/php-file-iterator) >= 4.0 with php-composer(phpunit/php-file-iterator) < 5)
Requires: (php-composer(phpunit/php-invoker) >= 4.0 with php-composer(phpunit/php-invoker) < 5)
Requires: (php-composer(phpunit/php-text-template) >= 3.0 with php-composer(phpunit/php-text-template) < 4)
@@ -162,7 +162,7 @@ Suggests: php-soap
Requires: php-myclabs-deep-copy >= 1.10.1
Requires: php-phar-io-manifest2 >= 2.0.3
Requires: php-phar-io-version3 >= 3.0.2
-Requires: php-phpunit-php-code-coverage10
+Requires: php-phpunit-php-code-coverage10 >= 10.1
Requires: php-phpunit-php-file-iterator4
Requires: php-phpunit-php-invoker4
Requires: php-phpunit-php-text-template3
@@ -256,6 +256,8 @@ cat src/autoload.php
--exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-92-is-detected/src/Greeter.php' \
--exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-92-is-detected/tests/GreeterTest.php' \
--exclude 'tests/end-to-end/logging/_files/teamcity-warning/tests/Test.php' \
+ --exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-100-is-detected/tests/GreeterTest.php' \
+ --exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-95-is-detected/src/Greeter.php' \
tests
@@ -294,6 +296,10 @@ exit $ret
%changelog
+* Fri Apr 14 2023 Remi Collet <remi@remirepo.net> - 10.1.0-1
+- update to 10.1.0
+- raise dependency on phpunit/php-code-coverage 10.1
+
* Mon Mar 27 2023 Remi Collet <remi@remirepo.net> - 10.0.19-1
- update to 10.0.19