summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-02 10:21:22 +0200
committerRemi Collet <remi@php.net>2023-06-02 10:21:22 +0200
commitb47e1338c1d5c6de329df722104e0d5182fe5166 (patch)
treee96613a8b59e99826233d0c8afcd77b4afb3a364
parent46fe4800e12e8faf4b9e662faa191fbb1de7b098 (diff)
update to 10.2.0
-rw-r--r--composer.json2
-rw-r--r--phpunit10.spec31
2 files changed, 18 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index da2081c..51d25b0 100644
--- a/composer.json
+++ b/composer.json
@@ -83,7 +83,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "10.1-dev"
+ "dev-main": "10.2-dev"
}
}
}
diff --git a/phpunit10.spec b/phpunit10.spec
index 6768507..e94e788 100644
--- a/phpunit10.spec
+++ b/phpunit10.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 2379ebafc1737e71cdc84f402acb6b7f04198b9d
+%global gh_commit 3aad97fde1f3e490e2b316ba56bc4680310e3c3f
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -23,9 +23,9 @@
%global ns_vendor PHPUnit10
%global php_home %{_datadir}/php
%global ver_major 10
-%global ver_minor 1
+%global ver_minor 2
-%global upstream_version 10.1.3
+%global upstream_version 10.2.0
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -248,18 +248,18 @@ cat src/autoload.php
--output tests/autoload.php \
--exclude 'tests/end-to-end/regression/4376/tests/Test.php' \
--exclude 'tests/end-to-end/regression/2448/Test.php' \
- --exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-85-is-detected/src/Greeter.php' \
- --exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-85-is-detected/tests/GreeterTest.php' \
- --exclude 'tests/end-to-end/_files/coverage-annotation-based-filter/src/AnnotationFilter.php' \
- --exclude 'tests/end-to-end/_files/coverage-annotation-based-filter/tests/AnnotationFilterTest.php' \
- --exclude 'tests/end-to-end/event/_files/extension-bootstrap/tests/Test.php' \
- --exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-92-is-detected/src/Greeter.php' \
- --exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-92-is-detected/tests/GreeterTest.php' \
- --exclude 'tests/end-to-end/logging/_files/teamcity-warning/tests/Test.php' \
- --exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-100-is-detected/tests/GreeterTest.php' \
- --exclude 'tests/end-to-end/migration/_files/possibility-to-migrate-from-95-is-detected/src/Greeter.php' \
+ --exclude 'tests/*/_files/*.php' \
tests
-
+cat << 'EOF' | tee -a tests/autoload.php
+// Dependencies
+\Fedora\Autoloader\Dependencies::required([
+ __DIR__ . '/_files/CoverageNamespacedFunctionTest.php',
+ __DIR__ . '/_files/CoveredFunction.php',
+ __DIR__ . '/_files/NamespaceCoveredFunction.php',
+ __DIR__ . '/end-to-end/code-coverage/ignore-function-using-attribute/src/CoveredFunction.php',
+ __DIR__ . '/end-to-end/execution-order/_files/MultiDependencyTest.php',
+]);
+EOF
%install
mkdir -p %{buildroot}%{php_home}
@@ -297,6 +297,9 @@ exit $ret
%changelog
+* Fri Jun 2 2023 Remi Collet <remi@remirepo.net> - 10.2.0-1
+- update to 10.2.0
+
* Thu May 11 2023 Remi Collet <remi@remirepo.net> - 10.1.3-1
- update to 10.1.3