summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-02 12:18:14 +0200
committerRemi Collet <remi@php.net>2023-08-02 12:18:14 +0200
commit529b5dc06fc611cea9fc8fb8ec17cfdf0b78b88b (patch)
tree7e73f312a0d34fc7095302a1f368f938f7881233
parent47de832067649163f08f1c830797a7beff53e4e2 (diff)
update to 10.2.7
raise dependency on sebastian/global-state 6.0.1
-rw-r--r--composer.json2
-rw-r--r--phpunit10.spec27
2 files changed, 20 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 51d25b0..ca3cc15 100644
--- a/composer.json
+++ b/composer.json
@@ -43,7 +43,7 @@
"sebastian/diff": "^5.0",
"sebastian/environment": "^6.0",
"sebastian/exporter": "^5.0",
- "sebastian/global-state": "^6.0",
+ "sebastian/global-state": "^6.0.1",
"sebastian/object-enumerator": "^5.0",
"sebastian/recursion-context": "^5.0",
"sebastian/type": "^4.0",
diff --git a/phpunit10.spec b/phpunit10.spec
index c692252..42a5cdd 100644
--- a/phpunit10.spec
+++ b/phpunit10.spec
@@ -8,10 +8,15 @@
# Please, preserve the changelog entries
#
+# remirepo:4
+%if "%{?vendeur}" == "remi"
# For compatibility with SCL
%undefine __brp_mangle_shebangs
+%endif
+
+%bcond_without tests
-%global gh_commit 1c17815c129f133f3019cc18e8d0c8622e6d9bcd
+%global gh_commit a215d9ee8bac1733796e4ddff3306811f14414e5
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -25,7 +30,7 @@
%global ver_major 10
%global ver_minor 2
-%global upstream_version 10.2.6
+%global upstream_version 10.2.7
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -60,7 +65,7 @@ BuildRequires: (php-composer(sebastian/comparator) >= 5.0 with php-c
BuildRequires: (php-composer(sebastian/diff) >= 5.0 with php-composer(sebastian/diff) < 6)
BuildRequires: (php-composer(sebastian/environment) >= 6.0 with php-composer(sebastian/environment) < 7)
BuildRequires: (php-composer(sebastian/exporter) >= 5.0 with php-composer(sebastian/exporter) < 6)
-BuildRequires: (php-composer(sebastian/global-state) >= 6.0 with php-composer(sebastian/global-state) < 7)
+BuildRequires: (php-composer(sebastian/global-state) >= 6.0.1 with php-composer(sebastian/global-state) < 7)
BuildRequires: (php-composer(sebastian/object-enumerator) >= 5.0 with php-composer(sebastian/object-enumerator) < 6)
BuildRequires: (php-composer(sebastian/recursion-context) >= 5.0 with php-composer(sebastian/recursion-context) < 6)
BuildRequires: (php-composer(sebastian/type) >= 4.0 with php-composer(sebastian/type) < 5)
@@ -81,7 +86,7 @@ BuildRequires: php-sebastian-comparator5
BuildRequires: php-sebastian-diff5
BuildRequires: php-sebastian-environment6
BuildRequires: php-sebastian-exporter5
-BuildRequires: php-sebastian-global-state6
+BuildRequires: php-sebastian-global-state6 >= 6.0.1
BuildRequires: php-sebastian-object-enumerator5
BuildRequires: php-sebastian-recursion-context5
BuildRequires: php-sebastian-type4
@@ -118,7 +123,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "sebastian/diff": "^5.0",
# "sebastian/environment": "^6.0",
# "sebastian/exporter": "^5.0",
-# "sebastian/global-state": "^6.0",
+# "sebastian/global-state": "^6.0.1",
# "sebastian/object-enumerator": "^5.0",
# "sebastian/recursion-context": "^5.0",
# "sebastian/type": "^4.0",
@@ -147,7 +152,7 @@ Requires: (php-composer(sebastian/comparator) >= 5.0 with php-c
Requires: (php-composer(sebastian/diff) >= 5.0 with php-composer(sebastian/diff) < 6)
Requires: (php-composer(sebastian/environment) >= 6.0 with php-composer(sebastian/environment) < 7)
Requires: (php-composer(sebastian/exporter) >= 5.0 with php-composer(sebastian/exporter) < 6)
-Requires: (php-composer(sebastian/global-state) >= 6.0 with php-composer(sebastian/global-state) < 7)
+Requires: (php-composer(sebastian/global-state) >= 6.0.1 with php-composer(sebastian/global-state) < 7)
Requires: (php-composer(sebastian/object-enumerator) >= 5.0 with php-composer(sebastian/object-enumerator) < 6)
Requires: (php-composer(sebastian/recursion-context) >= 5.0 with php-composer(sebastian/recursion-context) < 6)
Requires: (php-composer(sebastian/type) >= 4.0 with php-composer(sebastian/type) < 5)
@@ -173,7 +178,7 @@ Requires: php-sebastian-comparator5
Requires: php-sebastian-diff5
Requires: php-sebastian-environment6
Requires: php-sebastian-exporter5
-Requires: php-sebastian-global-state6
+Requires: php-sebastian-global-state6 >= 6.0.1
Requires: php-sebastian-object-enumerator5
Requires: php-sebastian-recursion-context5
Requires: php-sebastian-type4
@@ -271,6 +276,7 @@ install -D -p -m 755 phpunit %{buildroot}%{_bindir}/%{name}
install -p -m 644 phpunit.xsd %{buildroot}%{php_home}/%{ns_vendor}/phpunit.xsd
+%if %{with tests}
%check
# ignore tests relying on git layout
OPT='--filter "^((?!(testIsInitialized|testExclusionOfFileCanBeQueried)).)*$" --testsuite=unit --no-coverage'
@@ -278,12 +284,13 @@ sed -e 's:@PATH@:%{buildroot}%{php_home}/%{ns_vendor}:' -i tests/bootstrap.php
sed -e 's:%{php_home}/%{ns_vendor}:%{buildroot}%{php_home}/%{ns_vendor}:' -i phpunit
ret=0
-for cmd in php php81 php82; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd ./phpunit $OPT || ret=1
fi
done
exit $ret
+%endif
%files
@@ -297,6 +304,10 @@ exit $ret
%changelog
+* Wed Aug 2 2023 Remi Collet <remi@remirepo.net> - 10.2.7-1
+- update to 10.2.7
+- raise dependency on sebastian/global-state 6.0.1
+
* Tue Jul 18 2023 Remi Collet <remi@remirepo.net> - 10.2.6-1
- update to 10.2.6