summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-15 07:35:16 +0100
committerRemi Collet <remi@php.net>2024-01-15 07:35:16 +0100
commit26da0e3e46f1b5811e99912598ce2499c46a965d (patch)
treee1f30dae83cf52f280d9aecb809cb63702cf90a8
parent43a77b8c4c93d4eb5f6c524837d58cea3a97f0f8 (diff)
update to 10.5.7
-rw-r--r--phpunit10-rpm.patch22
-rw-r--r--phpunit10.spec9
2 files changed, 18 insertions, 13 deletions
diff --git a/phpunit10-rpm.patch b/phpunit10-rpm.patch
index 2e82286..9ddfc8c 100644
--- a/phpunit10-rpm.patch
+++ b/phpunit10-rpm.patch
@@ -1,7 +1,7 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2023-04-14 10:47:29.000000000 +0200
-+++ ./phpunit 2023-04-14 10:49:23.217236377 +0200
-@@ -71,29 +71,25 @@ if (isset($GLOBALS['_composer_autoload_p
+--- ./phpunit.rpm 2024-01-15 07:31:36.850034357 +0100
++++ ./phpunit 2024-01-15 07:33:02.306130486 +0100
+@@ -46,27 +46,13 @@ if (isset($GLOBALS['_composer_autoload_p
define('PHPUNIT_COMPOSER_INSTALL', $GLOBALS['_composer_autoload_path']);
unset($GLOBALS['_composer_autoload_path']);
@@ -13,10 +13,10 @@ diff -up ./phpunit.rpm ./phpunit
- break;
- }
- }
--
+
- unset($file);
-}
-
+-
-if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
- fwrite(
- STDERR,
@@ -34,9 +34,11 @@ diff -up ./phpunit.rpm ./phpunit
}
require PHPUNIT_COMPOSER_INSTALL;
+@@ -101,4 +87,13 @@ if ([] !== $unavailableExtensions) {
+
+ unset($requiredExtensions, $unavailableExtensions);
-exit((new PHPUnit\TextUI\Application)->run($_SERVER['argv']));
-+
+if (class_exists('PHPUnit\\TextUI\\Application')) {
+ // PHPUnit v10 or newer
+ exit((new PHPUnit\TextUI\Application)->run($_SERVER['argv']));
@@ -48,8 +50,8 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main();
+}
diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Configuration/Xml/SchemaFinder.php
---- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2023-04-14 10:51:13.796036447 +0200
-+++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2023-04-14 10:53:03.227838557 +0200
+--- ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm 2024-01-15 07:25:40.000000000 +0100
++++ ./src/TextUI/Configuration/Xml/SchemaFinder.php 2024-01-15 07:31:36.850034357 +0100
@@ -48,6 +48,6 @@ final class SchemaFinder
return __PHPUNIT_PHAR_ROOT__ . '/';
}
@@ -59,8 +61,8 @@ diff -up ./src/TextUI/Configuration/Xml/SchemaFinder.php.rpm ./src/TextUI/Config
}
}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2023-04-14 10:47:29.000000000 +0200
-+++ ./tests/bootstrap.php 2023-04-14 10:49:23.217236377 +0200
+--- ./tests/bootstrap.php.rpm 2024-01-15 07:25:39.000000000 +0100
++++ ./tests/bootstrap.php 2024-01-15 07:31:36.851034393 +0100
@@ -11,8 +11,8 @@ if (!defined('TEST_FILES_PATH')) {
define('TEST_FILES_PATH', __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR);
}
diff --git a/phpunit10.spec b/phpunit10.spec
index f257d53..61d74b5 100644
--- a/phpunit10.spec
+++ b/phpunit10.spec
@@ -20,8 +20,8 @@
%bcond_with defcmd
%endif
-%global gh_commit ab9a20b623b235165d24faa9d1da925cb54939c0
-%global gh_date 2024-01-13
+%global gh_commit e5c5b397a95cb0db013270a985726fcae93e61b8
+%global gh_date 2024-01-14
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -34,7 +34,7 @@
%global ver_major 10
%global ver_minor 5
-%global upstream_version 10.5.6
+%global upstream_version 10.5.7
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -319,6 +319,9 @@ exit $ret
%changelog
+* Mon Jan 15 2024 Remi Collet <remi@remirepo.net> - 10.5.7-1
+- update to 10.5.7
+
* Sun Jan 14 2024 Remi Collet <remi@remirepo.net> - 10.5.6-1
- update to 10.5.6