summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json11
-rw-r--r--php-sebastian-type5.spec36
2 files changed, 28 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index faf8a0e..39b82cd 100644
--- a/composer.json
+++ b/composer.json
@@ -12,18 +12,19 @@
}
],
"support": {
- "issues": "https://github.com/sebastianbergmann/type/issues"
+ "issues": "https://github.com/sebastianbergmann/type/issues",
+ "security": "https://github.com/sebastianbergmann/type/security/policy"
},
"prefer-stable": true,
"require": {
- "php": ">=8.1"
+ "php": ">=8.2"
},
"require-dev": {
- "phpunit/phpunit": "^10.0"
+ "phpunit/phpunit": "^11.0"
},
"config": {
"platform": {
- "php": "8.1.0"
+ "php": "8.2.0"
},
"optimize-autoloader": true,
"sort-packages": true
@@ -44,7 +45,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "4.0-dev"
+ "dev-main": "5.0-dev"
}
}
}
diff --git a/php-sebastian-type5.spec b/php-sebastian-type5.spec
index 1f2dfe3..46a27d4 100644
--- a/php-sebastian-type5.spec
+++ b/php-sebastian-type5.spec
@@ -1,31 +1,33 @@
-# remirepo/fedora spec file for php-sebastian-type4
+# remirepo/fedora spec file for php-sebastian-type5
#
-# Copyright (c) 2019-2023 Remi Collet
+# Copyright (c) 2019-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%bcond_without tests
+# disabled until phpunit11 available
+%bcond_with tests
# github
-%global gh_commit 462699a16464c3944eefc02ebdd77882bd3925bf
+%global gh_commit b8502785eb3523ca0dd4afe9ca62235590020f3f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project type
+%global gh_date 2024-02-02
# packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
-%global major 4
+%global major 5
# namespace
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project Type
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.0
-Release: 3%{?dist}
+Version: 5.0.0
+Release: 1%{?dist}
Summary: Collection of value objects that represent the types of the PHP type system, v%{major}
License: BSD-3-Clause
@@ -34,19 +36,19 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.1
+BuildRequires: php(language) >= 8.2
BuildRequires: php-reflection
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^10.0"
-BuildRequires: phpunit10
+# "phpunit/phpunit": "^11.0"
+BuildRequires: phpunit11
%endif
# from composer.json, "require": {
-# "php": ">=8.1",
-Requires: php(language) >= 8.1
+# "php": ">=8.2",
+Requires: php(language) >= 8.2
# from phpcompatinfo report for version 4.0.0
Requires: php-reflection
# Autoloader
@@ -92,10 +94,10 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php81 php82 php83; do
+for cmd in php php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit10 || ret=1
+ %{_bindir}/phpunit11 || ret=1
fi
done
exit $ret
@@ -115,6 +117,12 @@ exit $ret
%changelog
+* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 5.0.0-1
+- update to 5.0.0
+- raise dependency on PHP 8.2
+- rename to php-sebastian-type5
+- move to /usr/share/php/SebastianBergmann/Type5
+
* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 4.0.0-3
- Enable test suite