summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--ResourceOperationsTest.php29
-rw-r--r--composer.json26
-rw-r--r--php-sebastian-resource-operations2.spec126
4 files changed, 189 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/ResourceOperationsTest.php b/ResourceOperationsTest.php
new file mode 100644
index 0000000..176bc0d
--- /dev/null
+++ b/ResourceOperationsTest.php
@@ -0,0 +1,29 @@
+<?php
+/*
+ * This file is part of resource-operations.
+ *
+ * (c) Sebastian Bergmann <sebastian@phpunit.de>
+ *
+ * For the full copyright and license information, please view the LICENSE
+ * file that was distributed with this source code.
+ */
+
+namespace SebastianBergmann\ResourceOperations;
+
+use PHPUnit_Framework_TestCase;
+
+/**
+ * @covers SebastianBergmann\ResourceOperations\ResourceOperations
+ */
+class ResourceOperationsTest extends PHPUnit_Framework_TestCase
+{
+ /**
+ * @covers SebastianBergmann\ResourceOperations\ResourceOperations::getFunctions
+ */
+ public function testGetFunctions()
+ {
+ $tab = ResourceOperations::getFunctions();
+ $this->assertTrue(is_array($tab), 'ResourceOperations::getFunctions does not return an array');
+ $this->assertContains('zip_open', $tab);
+ }
+}
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..da495d6
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,26 @@
+{
+ "name": "sebastian/resource-operations",
+ "description": "Provides a list of PHP built-in functions that operate on resources",
+ "homepage": "https://www.github.com/sebastianbergmann/resource-operations",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de"
+ }
+ ],
+ "require": {
+ "php": ">=5.6.0"
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0.x-dev"
+ }
+ }
+}
+
diff --git a/php-sebastian-resource-operations2.spec b/php-sebastian-resource-operations2.spec
new file mode 100644
index 0000000..0c40b69
--- /dev/null
+++ b/php-sebastian-resource-operations2.spec
@@ -0,0 +1,126 @@
+# remirepo/fedora spec file for php-sebastian-resource-operations
+#
+# Copyright (c) 2015-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit ce990bb21759f94aeafd30209e8cfcdfa8bc3f52
+#global gh_date 20150728
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project resource-operations
+%global php_home %{_datadir}/php
+%global ns_vendor SebastianBergmann
+%global ns_project ResourceOperations
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-sebastian-resource-operations
+Version: 1.0.0
+%global specrel 2
+Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Summary: Provides a list of PHP built-in functions that operate on resources
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+# https://github.com/sebastianbergmann/resource-operations/pull/2
+Source1: https://raw.githubusercontent.com/remicollet/resource-operations/issue-tests/tests/ResourceOperationsTest.php
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-fedora-autoloader-devel
+%if %{with_tests}
+BuildRequires: %{_bindir}/phpunit
+%endif
+
+# from composer.json
+# "php": ">=5.6.0"
+Requires: php(language) >= 5.6
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# from phpcompatinfo report for version 1.0.0: nothing
+
+Provides: php-composer(sebastian/resource-operations) = %{version}
+
+
+%description
+%{summary}.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mkdir tests
+cp %{SOURCE1} tests/
+
+
+%build
+# Generate the Autoloader
+phpab --template fedora --output src/autoload.php src
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%check
+%if %{with_tests}
+: Run upstream test suite
+# remirepo:13
+run=0
+ret=0
+if which php56; then
+ php56 -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+ %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php tests || ret=1
+ run=1
+fi
+if which php71; then
+ php71 -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+ %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php tests || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+%{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php tests --verbose
+# remirepo:2
+fi
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md composer.json
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Mon Oct 31 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
+- switch to fedora/autoloader
+
+* Fri Oct 2 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Update to 1.0.0 (no change)
+
+* Tue Sep 29 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.1.20150728gitce990bb
+- initial package