summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-04 07:26:22 +0200
committerRemi Collet <remi@remirepo.net>2018-10-04 07:26:22 +0200
commit228b03c14df0adfab6bd102c423dcaf73aec4f88 (patch)
tree7e5d938577555cccb0d16a9f62459e92bef151c9
parent88855dc1c76526cc10710b9d440b4ac2b97226b4 (diff)
update to 2.0.1
drop patch merged upstream
-rw-r--r--ResourceOperationsTest.php29
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-resource-operations2.spec15
3 files changed, 7 insertions, 39 deletions
diff --git a/ResourceOperationsTest.php b/ResourceOperationsTest.php
deleted file mode 100644
index 0e0fcc0..0000000
--- a/ResourceOperationsTest.php
+++ /dev/null
@@ -1,29 +0,0 @@
-<?php
-/*
- * This file is part of resource-operations.
- *
- * (c) Sebastian Bergmann <sebastian@phpunit.de>
- *
- * For the full copyright and license information, please view the LICENSE
- * file that was distributed with this source code.
- */
-
-namespace SebastianBergmann\ResourceOperations;
-
-use PHPUnit\Framework\TestCase;
-
-/**
- * @covers SebastianBergmann\ResourceOperations\ResourceOperations
- */
-class ResourceOperationsTest extends TestCase
-{
- /**
- * @covers SebastianBergmann\ResourceOperations\ResourceOperations::getFunctions
- */
- public function testGetFunctions()
- {
- $tab = ResourceOperations::getFunctions();
- $this->assertTrue(is_array($tab), 'ResourceOperations::getFunctions does not return an array');
- $this->assertContains('zip_open', $tab);
- }
-}
diff --git a/composer.json b/composer.json
index 0e05865..a5e2320 100644
--- a/composer.json
+++ b/composer.json
@@ -26,7 +26,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.0"
+ "dev-master": "2.0-dev"
}
}
}
diff --git a/php-sebastian-resource-operations2.spec b/php-sebastian-resource-operations2.spec
index ee10695..d0bba09 100644
--- a/php-sebastian-resource-operations2.spec
+++ b/php-sebastian-resource-operations2.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 756a75a44cb3164fd47435c36336e464c5028b34
+%global gh_commit 4d7a795d35b889bf80a0cc04e08d77cedfa917a9
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -23,7 +23,7 @@
%endif
Name: php-sebastian-resource-operations%{major}
-Version: 2.0.0
+Version: 2.0.1
%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Provides a list of PHP built-in functions that operate on resources
@@ -32,9 +32,6 @@ License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-# https://github.com/sebastianbergmann/resource-operations/pull/2
-Source1: https://raw.githubusercontent.com/remicollet/resource-operations/issue-tests/tests/ResourceOperationsTest.php
-
BuildArch: noarch
BuildRequires: php(language) >= 7.1
BuildRequires: php-fedora-autoloader-devel
@@ -63,9 +60,6 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-mkdir tests
-cp %{SOURCE1} tests/
-
%build
# Generate the Autoloader
@@ -80,7 +74,6 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
%if %{with_tests}
: Run upstream test suite
-: Run upstream test suite
ret=0
for cmd in php php71 php72 php73; do
if which $cmd; then
@@ -103,6 +96,10 @@ exit $ret
%changelog
+* Thu Oct 4 2018 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1
+- drop patch merged upstream
+
* Fri Sep 28 2018 Remi Collet <remi@remirepo.net> - 2.0.0-1
- update to 2.0.0
- raise dependency on PHP 7.1