summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-02-05 11:47:05 +0100
committerRemi Collet <remi@php.net>2024-02-05 11:47:05 +0100
commitc5edf287ec542ba93b0e66567ef9f32e78e0a33a (patch)
tree29f996037068b1686c9213ab5e325e09f0c85021
parent27e514d20bd9feaae03a9fff842f049828c8ab5c (diff)
update to 3.0.0HEADmaster
raise dependency on PHP 8.2 raise dependency on nikic/php-parser 5.0 rename to php-sebastian-lines-of-code3 move to /usr/share/php/SebastianBergmann/LinesOfCode3
-rw-r--r--composer.json10
-rw-r--r--php-sebastian-lines-of-code3.spec48
2 files changed, 32 insertions, 26 deletions
diff --git a/composer.json b/composer.json
index 1f3b747..46f1243 100644
--- a/composer.json
+++ b/composer.json
@@ -17,15 +17,15 @@
},
"prefer-stable": true,
"require": {
- "php": ">=8.1",
- "nikic/php-parser": "^4.18 || ^5.0"
+ "php": ">=8.2",
+ "nikic/php-parser": "^5.0"
},
"require-dev": {
- "phpunit/phpunit": "^10.0"
+ "phpunit/phpunit": "^11.0"
},
"config": {
"platform": {
- "php": "8.1"
+ "php": "8.2"
},
"optimize-autoloader": true,
"sort-packages": true
@@ -37,7 +37,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "2.0-dev"
+ "dev-main": "3.0-dev"
}
}
}
diff --git a/php-sebastian-lines-of-code3.spec b/php-sebastian-lines-of-code3.spec
index 9271fdf..a2cf4b2 100644
--- a/php-sebastian-lines-of-code3.spec
+++ b/php-sebastian-lines-of-code3.spec
@@ -1,30 +1,32 @@
-# remirepo/fedora spec file for php-sebastian-lines-of-code2
+# remirepo/fedora spec file for php-sebastian-lines-of-code3
#
-# Copyright (c) 2020-2023 Remi Collet
+# Copyright (c) 2020-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%bcond_without tests
+# disabled until phpunit11 available
+%bcond_with tests
# github
-%global gh_commit 856e7f6a75a84e339195d48c556f23be2ebf75d0
+%global gh_commit 376c5b3f6b43c78fdc049740bca76a7c846706c0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project lines-of-code
+%global gh_date 2024-02-02
# packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
-%global major 2
+%global major 3
# namespace
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project LinesOfCode
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.2
+Version: 3.0.0
Release: 1%{?dist}
Summary: Counting the lines of code in PHP source code, version %{major}
@@ -35,33 +37,33 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.1
+BuildRequires: php(language) >= 8.2
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(nikic/php-parser) >= 4.18 with php-composer(nikic/php-parser) < 6)
+BuildRequires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
# remirepo:3
%else
-BuildRequires: php-nikic-php-parser4 >= 4.18
+BuildRequires: php-nikic-php-parser5
%endif
BuildRequires: php-spl
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^10.0"
-BuildRequires: phpunit10
+# "phpunit/phpunit": "^11.0"
+BuildRequires: phpunit11
%endif
# from composer.json, "require": {
# "php": ">=8.1",
-# "nikic/php-parser": "^4.18 || ^5.0"
-Requires: php(language) >= 8.1
+# "nikic/php-parser": "^5.0"
+Requires: php(language) >= 8.2
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(nikic/php-parser) >= 4.18 with php-composer(nikic/php-parser) < 6)
+Requires: (php-composer(nikic/php-parser) >= 5.0 with php-composer(nikic/php-parser) < 6)
# remirepo:3
%else
-Requires: php-nikic-php-parser4 >= 4.18
+Requires: php-nikic-php-parser5
%endif
# from phpcompatinfo report for version 2.0.0
Requires: php-spl
@@ -89,10 +91,7 @@ phpab --template fedora --output src/autoload.php src
cat <<EOF | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- [
- '%{php_home}/PhpParser5/autoload.php',
- '%{php_home}/PhpParser4/autoload.php',
- ],
+ '%{php_home}/PhpParser5/autoload.php',
]);
EOF
@@ -109,10 +108,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php81 php82 php83; do
+for cmd in php php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit10 || ret=1
+ %{_bindir}/phpunit11 || ret=1
fi
done
exit $ret
@@ -132,6 +131,13 @@ exit $ret
%changelog
+* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- raise dependency on PHP 8.2
+- raise dependency on nikic/php-parser 5.0
+- rename to php-sebastian-lines-of-code3
+- move to /usr/share/php/SebastianBergmann/LinesOfCode3
+
* Thu Dec 21 2023 Remi Collet <remi@remirepo.net> - 2.0.2-1
- update to 2.0.2
- raise dependency on nikic/php-parser 4.18 and allow 5.0