summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-sebastian-global-state3-tests.patch12
-rw-r--r--php-sebastian-global-state3.spec58
4 files changed, 88 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 166649d..0cbc33d 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,7 @@
"sort-packages": true
},
"require": {
- "php": "^7.2",
+ "php": ">=7.2",
"sebastian/object-reflector": "^1.1.1",
"sebastian/recursion-context": "^3.0"
},
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..3d8028d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-sebastian-global-state3-tests.patch b/php-sebastian-global-state3-tests.patch
new file mode 100644
index 0000000..6ed9d52
--- /dev/null
+++ b/php-sebastian-global-state3-tests.patch
@@ -0,0 +1,12 @@
+diff -up ./tests/CodeExporterTest.php.old ./tests/CodeExporterTest.php
+--- ./tests/CodeExporterTest.php.old 2021-11-05 12:23:16.685055861 +0100
++++ ./tests/CodeExporterTest.php 2021-11-05 12:23:19.837046004 +0100
+@@ -21,7 +21,7 @@ final class CodeExporterTest extends Tes
+ */
+ public function testCanExportGlobalVariablesToCode(): void
+ {
+- $GLOBALS = ['foo' => 'bar'];
++ $GLOBALS['foo'] = 'bar';
+
+ $snapshot = new Snapshot(null, true, false, false, false, false, false, false, false, false);
+
diff --git a/php-sebastian-global-state3.spec b/php-sebastian-global-state3.spec
index a6c4ff4..139ecfc 100644
--- a/php-sebastian-global-state3.spec
+++ b/php-sebastian-global-state3.spec
@@ -1,13 +1,13 @@
# spec file for php-sebastian-global-state3
#
-# Copyright (c) 2014-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2014-2024 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit edf8a461cf1d4005f19fb0b6b8b95a9f7fa0adc4
+%global gh_commit 91c7c47047a971f02de57ed6f040087ef110c5d9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project global-state
@@ -24,13 +24,16 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.0
-Release: 2%{?dist}
-Summary: Snapshotting of global state
+Version: 3.0.5
+Release: 1%{?dist}
+Summary: Snapshotting of global state, version %{major}
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+Patch0: %{name}-tests.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.2
@@ -56,7 +59,7 @@ BuildRequires: php-dom
%endif
# from composer.json, "require": {
-# "php": "^7.2",
+# "php": ">=7.2",
# "sebastian/object-reflector": "^1.1.1",
# "sebastian/recursion-context": "^3.0"
Requires: php(language) >= 7.2
@@ -87,9 +90,14 @@ Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
Snapshotting of global state,
factored out of PHPUnit into a stand-alone component.
+This package provides the version %{major} of the library.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch -P0 -p1
%build
@@ -123,10 +131,13 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php72 php73; do
+# testCanExportGlobalVariablesToCode reports our autoloader
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit8 --verbose || ret=1
+ %{_bindir}/phpunit8 \
+ --filter "^((?!(testCanExportGlobalVariablesToCode)).)*$" \
+ --verbose || ret=1
fi
done
exit $ret
@@ -146,6 +157,31 @@ exit $ret
%changelog
+* Tue Mar 5 2024 Remi Collet <remi@remirepo.net> - 3.0.5-1
+- update to 3.0.5
+
+* Fri Mar 1 2024 Remi Collet <remi@remirepo.net> - 3.0.4-1
+- update to 3.0.4 (no change)
+- sources from git snapshot
+
+* Wed Aug 2 2023 Remi Collet <remi@remirepo.net> - 3.0.3-1
+- update to 3.0.3
+
+* Fri Apr 21 2023 Remi Collet <remi@remirepo.net> - 3.0.2-4
+- improve description and summary
+
+* Thu Dec 15 2022 Remi Collet <remi@remirepo.net> - 3.0.2-2
+- use SPDX License id
+
+* Thu Feb 10 2022 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+
+* Mon Nov 8 2021 Remi Collet <remi@remirepo.net> - 3.0.1-4
+- fix FTBFS with 8.1
+
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1 (no change)
+
* Fri Feb 22 2019 Remi Collet <remi@remirepo.net> - 3.0.0-2
- normal build