summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-03-01 15:48:14 +0100
committerRemi Collet <remi@php.net>2024-03-01 15:48:14 +0100
commitfdca3f70f1c2e0dfc9300fc2ea919e1552f44747 (patch)
tree59c46ea02aa59f375607cfa2d6043f1a013c325f
parent5ddd7cc034115f7b80515e86b389849aef6468ea (diff)
update to 3.0.4 (no change)
sources from git snapshot
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-sebastian-global-state3.spec15
2 files changed, 38 insertions, 5 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..3d8028d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-sebastian-global-state3.spec b/php-sebastian-global-state3.spec
index 91c22a0..ba8212d 100644
--- a/php-sebastian-global-state3.spec
+++ b/php-sebastian-global-state3.spec
@@ -1,13 +1,13 @@
# spec file for php-sebastian-global-state3
#
-# Copyright (c) 2014-2023 Remi Collet
+# Copyright (c) 2014-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 66783ce213de415b451b904bfef9dda0cf9aeae0
+%global gh_commit 3b7bb09ded5565e87da9357f423ec4b69c4f4e06
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project global-state
@@ -24,13 +24,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.3
+Version: 3.0.4
Release: 1%{?dist}
Summary: Snapshotting of global state, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
Patch0: %{name}-tests.patch
@@ -131,7 +132,7 @@ EOF
: Run upstream test suite
ret=0
# testCanExportGlobalVariablesToCode reports our autoloader
-for cmd in php php80 php81 php82 php83; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit8 \
@@ -156,6 +157,10 @@ exit $ret
%changelog
+* Fri Mar 1 2024 Remi Collet <remi@remirepo.net> - 3.0.4-1
+- update to 3.0.4 (no change)
+- sources from git snapshot
+
* Wed Aug 2 2023 Remi Collet <remi@remirepo.net> - 3.0.3-1
- update to 3.0.3