summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-environment7.spec26
2 files changed, 16 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index f7280d6..b2bc179 100644
--- a/composer.json
+++ b/composer.json
@@ -38,7 +38,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "7.1-dev"
+ "dev-main": "7.2-dev"
}
}
}
diff --git a/php-sebastian-environment7.spec b/php-sebastian-environment7.spec
index 0497f7b..4921a06 100644
--- a/php-sebastian-environment7.spec
+++ b/php-sebastian-environment7.spec
@@ -1,21 +1,21 @@
# remirepo/fedora spec file for php-sebastian-environment7
#
-# Copyright (c) 2014-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2014-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
# disabled until phpunit11 available
-%bcond_with tests
+%bcond_without tests
# Sources
-%global gh_commit 4eb3a442574d0e9d141aab209cd4aaf25701b09a
+%global gh_commit 855f3ae0ab316bbafe1ba4e16e9f3c078d24a0c5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project environment
-%global gh_date 2024-03-23
+%global gh_date 2024-07-03
# Packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
@@ -26,8 +26,8 @@
%global ns_project Environment
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 7.1.0
-Release: 1%{?dist}
+Version: 7.2.0
+Release: 2%{?dist}
Summary: Handle HHVM/PHP environments, version %{major}
License: BSD-3-Clause
@@ -94,7 +94,7 @@ touch vendor/autoload.php
: Run tests
ret=0
-for cmd in php php82 php83; do
+for cmd in php php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
-d pcov.enabled=1 \
@@ -106,8 +106,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md composer.json
%dir %{php_home}/%{ns_vendor}
@@ -115,6 +113,12 @@ exit $ret
%changelog
+* Tue Feb 4 2025 Remi Collet <remi@remirepo.net> - 7.2.0-2
+- enable test suite
+
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 7.2.0-1
+- update to 7.2.0
+
* Tue Mar 26 2024 Remi Collet <remi@remirepo.net> - 7.1.0-1
- update to 7.1.0