summaryrefslogtreecommitdiffstats
path: root/php-sebastian-environment4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-environment4.spec')
-rw-r--r--php-sebastian-environment4.spec28
1 files changed, 20 insertions, 8 deletions
diff --git a/php-sebastian-environment4.spec b/php-sebastian-environment4.spec
index 8032969..08c0b5a 100644
--- a/php-sebastian-environment4.spec
+++ b/php-sebastian-environment4.spec
@@ -1,14 +1,14 @@
# remirepo/fedora spec file for php-sebastian-environment4
#
-# Copyright (c) 2014-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2014-2024 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
# Sources
-%global gh_commit d47bbbad83711771f167c72d4e3f25f7fcc1f8b0
+%global gh_commit 56932f6049a0482853056ffd617c91ffcc754205
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project environment
@@ -27,13 +27,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.2.4
+Version: 4.2.5
Release: 1%{?dist}
-Summary: Handle HHVM/PHP environments
+Summary: Handle HHVM/PHP environments, version %{major}
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.1
@@ -63,6 +64,10 @@ Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
This component provides functionality that helps writing PHP code that
has runtime-specific (PHP / HHVM) execution paths.
+This package provides the version %{major} of the library.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
@@ -88,7 +93,7 @@ touch vendor/autoload.php
: Run tests
ret=0
-for cmd in php php72 php73 php74 php80; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit8 \
@@ -109,6 +114,13 @@ exit $ret
%changelog
+* Fri Mar 1 2024 Remi Collet <remi@remirepo.net> - 4.2.5-1
+- update to 4.2.5 (no change)
+- sources from git snapshot
+
+* Fri Apr 21 2023 Remi Collet <remi@remirepo.net> - 4.2.4-7
+- use SPDX license ID
+
* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 4.2.4-1
- update to 4.2.4 (no change)
- switch to phpunit8