summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-environment4.spec18
2 files changed, 13 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 584d360..d02bb38 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,7 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.1"
+ "php": ">=7.1"
},
"require-dev": {
"phpunit/phpunit": "^7.5"
diff --git a/php-sebastian-environment4.spec b/php-sebastian-environment4.spec
index 4f181ce..8032969 100644
--- a/php-sebastian-environment4.spec
+++ b/php-sebastian-environment4.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# Sources
-%global gh_commit 464c90d7bdf5ad4e8a6aea15c091fec0603d4368
+%global gh_commit d47bbbad83711771f167c72d4e3f25f7fcc1f8b0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project environment
@@ -27,7 +27,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.2.3
+Version: 4.2.4
Release: 1%{?dist}
Summary: Handle HHVM/PHP environments
@@ -44,11 +44,11 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with_tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^7.5"
-BuildRequires: phpunit7 >= 7.5
+BuildRequires: phpunit8
%endif
# from composer.json, "require": {
-# "php": "^7.1"
+# "php": ">=7.1"
Requires: php(language) >= 7.1
# From phpcompatinfo report for 4.0.1
Requires: php-pcre
@@ -88,10 +88,12 @@ touch vendor/autoload.php
: Run tests
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit7 --verbose || ret=1
+ %{_bindir}/phpunit8 \
+ --filter '^((?!(testCanCollectCodeCoverageWhenPcovExtensionIsEnabled|testPCOVCanBeDetected)).)*$' \
+ --verbose || ret=1
fi
done
exit $ret
@@ -107,6 +109,10 @@ exit $ret
%changelog
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 4.2.4-1
+- update to 4.2.4 (no change)
+- switch to phpunit8
+
* Wed Nov 20 2019 Remi Collet <remi@remirepo.net> - 4.2.3-1
- update to 4.2.3