summaryrefslogtreecommitdiffstats
path: root/php-sebastian-diff6.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-diff6.spec')
-rw-r--r--php-sebastian-diff6.spec34
1 files changed, 16 insertions, 18 deletions
diff --git a/php-sebastian-diff6.spec b/php-sebastian-diff6.spec
index 9ea6763..0eeba34 100644
--- a/php-sebastian-diff6.spec
+++ b/php-sebastian-diff6.spec
@@ -1,20 +1,20 @@
# remirepo/fedora spec file for php-sebastian-diff6
#
-# Copyright (c) 2013-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2013-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
# disabled until phpunit11 available
-%bcond_with tests
+%bcond_without tests
-%global gh_commit ab83243ecc233de5655b76f577711de9f842e712
+%global gh_commit b4ccd857127db5d41a5b676f24b51371d76d8544
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
-%global gh_date 2024-03-02
+%global gh_date 2024-07-03
# Packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
@@ -26,12 +26,13 @@
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 6.0.1
-Release: 1%{?dist}
+Version: 6.0.2
+Release: 2%{?dist}
Summary: Diff implementation, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
+# run makesrc.sh to create a git snapshot with test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
# php-symfony4 going to disapear, php-symfony5 not available, only used for tests
@@ -89,16 +90,9 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
mkdir vendor
%{_bindir}/phpab --output vendor/autoload.php tests process-%{symfony_version}
-# remirepo:5
-%if 0%{?rhel} == 7
-: Ignore tests using git command: unknown option 'unsafe-paths' with old git
-rm -r tests/Output/Integration
-rm tests/Utils/UnifiedDiffAssertTraitIntegrationTest.php
-%endif
-
: Run upstream test suite
ret=0
-for cmd in php php82 php83; do
+for cmd in php php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit11 || ret=1
@@ -111,8 +105,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc *.md
@@ -121,6 +113,12 @@ exit $ret
%changelog
+* Tue Feb 4 2025 Remi Collet <remi@remirepo.net> - 6.0.2-2
+- enable test suite
+
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 6.0.2-1
+- update to 6.0.2
+
* Tue Mar 5 2024 Remi Collet <remi@remirepo.net> - 6.0.1-1
- update to 6.0.1