summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-02-05 10:29:22 +0100
committerRemi Collet <remi@php.net>2024-02-05 10:29:22 +0100
commit8358ebce08a7942ccd4180ac6d4bbff72eb8b97d (patch)
tree3ae64977508adf52dc9263b470a3f6450c0ff126
parentde4d4ea912a67e243e3f3c10082ddc20ece79aa3 (diff)
update to 6.0.0
raise dependency on PHP 8.2 rename to php-sebastian-diff6 move to /usr/share/php/SebastianBergmann/Diff6
-rw-r--r--composer.json8
-rw-r--r--php-sebastian-diff6.spec35
2 files changed, 25 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index bc6c3a4..7e19a7d 100644
--- a/composer.json
+++ b/composer.json
@@ -21,16 +21,16 @@
"prefer-stable": true,
"config": {
"platform": {
- "php": "8.1.0"
+ "php": "8.2.0"
},
"optimize-autoloader": true,
"sort-packages": true
},
"require": {
- "php": ">=8.1"
+ "php": ">=8.2"
},
"require-dev": {
- "phpunit/phpunit": "^10.0",
+ "phpunit/phpunit": "^11.0",
"symfony/process": "^4.2 || ^5"
},
"autoload": {
@@ -45,7 +45,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "5.1-dev"
+ "dev-main": "6.0-dev"
}
}
}
diff --git a/php-sebastian-diff6.spec b/php-sebastian-diff6.spec
index af721e4..6a042be 100644
--- a/php-sebastian-diff6.spec
+++ b/php-sebastian-diff6.spec
@@ -1,15 +1,16 @@
-# remirepo/fedora spec file for php-sebastian-diff5
+# remirepo/fedora spec file for php-sebastian-diff6
#
-# Copyright (c) 2013-2023 Remi Collet
+# Copyright (c) 2013-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%bcond_without tests
+# disabled until phpunit11 available
+%bcond_with tests
-%global gh_commit fbf413a49e54f6b9b17e12d900ac7f6101591b7f
+%global gh_commit 3e3f502419518897a923aa1c64d51f9def2e0aff
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
@@ -20,11 +21,11 @@
%global ns_vendor SebastianBergmann
%global ns_project Diff
-%global major 5
+%global major 6
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.1.0
+Version: 6.0.0
Release: 1%{?dist}
Summary: Diff implementation, version %{major}
@@ -33,24 +34,24 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
# php-symfony4 going to disapear, php-symfony5 not available, only used for tests
-%global symfony_version 5.4.22
+%global symfony_version 5.4.35
Source2: https://github.com/symfony/process/archive/v%{symfony_version}/php-symfony-process-%{symfony_version}.tar.gz
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
-BuildRequires: php(language) >= 8.1
+BuildRequires: php(language) >= 8.2
BuildRequires: php-pcre
BuildRequires: php-spl
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^10.0",
+# "phpunit/phpunit": "^11.0",
# "symfony/process": "^4.2 || ^5"
-BuildRequires: phpunit10
+BuildRequires: phpunit11
%endif
# from composer.json
-# "php": ">=8.1"
-Requires: php(language) >= 8.1
+# "php": ">=8.2"
+Requires: php(language) >= 8.2
# from phpcompatinfo report for version 5.0.0
Requires: php-pcre
Requires: php-spl
@@ -96,10 +97,10 @@ rm tests/Utils/UnifiedDiffAssertTraitIntegrationTest.php
: Run upstream test suite
ret=0
-for cmd in php php81 php82 php83; do
+for cmd in php php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit10 || ret=1
+ %{_bindir}/phpunit11 || ret=1
fi
done
exit $ret
@@ -119,6 +120,12 @@ exit $ret
%changelog
+* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 6.0.0-1
+- update to 6.0.0
+- raise dependency on PHP 8.2
+- rename to php-sebastian-diff6
+- move to /usr/share/php/SebastianBergmann/Diff6
+
* Fri Dec 22 2023 Remi Collet <remi@remirepo.net> - 5.1.0-1
- update to 5.1.0