summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json15
-rw-r--r--php-sebastian-diff3.spec40
2 files changed, 37 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index 5aaa716..51b0083 100644
--- a/composer.json
+++ b/composer.json
@@ -1,7 +1,7 @@
{
"name": "sebastian/diff",
"description": "Diff implementation",
- "keywords": ["diff"],
+ "keywords": ["diff", "udiff", "unidiff", "unified diff"],
"homepage": "https://github.com/sebastianbergmann/diff",
"license": "BSD-3-Clause",
"authors": [
@@ -14,20 +14,27 @@
"email": "mail@kore-nordmann.de"
}
],
+ "minimum-stability": "dev",
"require": {
- "php": "^7.0"
+ "php": "^7.1"
},
"require-dev": {
- "phpunit/phpunit": "^6.2"
+ "phpunit/phpunit": "^7.0",
+ "symfony/process": "^2 || ^3.3 || ^4"
},
"autoload": {
"classmap": [
"src/"
]
},
+ "autoload-dev": {
+ "classmap": [
+ "tests/"
+ ]
+ },
"extra": {
"branch-alias": {
- "dev-master": "2.0-dev"
+ "dev-master": "3.0-dev"
}
}
}
diff --git a/php-sebastian-diff3.spec b/php-sebastian-diff3.spec
index 82d3f3d..c1c6cc8 100644
--- a/php-sebastian-diff3.spec
+++ b/php-sebastian-diff3.spec
@@ -1,21 +1,24 @@
-# remirepo/fedora spec file for php-sebastian-diff2
+# remirepo/fedora spec file for php-sebastian-diff3
#
-# Copyright (c) 2013-2017 Remi Collet
+# Copyright (c) 2013-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
-%global gh_commit 347c1d8b49c5c3ee30c7040ea6fc446790e6bddd
+%global bootstrap 1
+%global gh_commit e09160918c66281713f1c324c1f4c4c3037ba1e8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
+# Packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
+# Namespace
%global ns_vendor SebastianBergmann
%global ns_project Diff
-%global major 2
+
+%global major 3
%global php_home %{_datadir}/php
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -24,8 +27,8 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.1
-Release: 1%{?dist}
+Version: 3.0.0
+Release: 0%{?dist}
Summary: Diff implementation
Group: Development/Libraries
@@ -36,19 +39,20 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.1
BuildRequires: php-pcre
BuildRequires: php-spl
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^6.2"
-BuildRequires: phpunit6 >= 6.2
-BuildRequires: php-reflection
+# "phpunit/phpunit": "^7.0",
+# "symfony/process": "^2 || ^3.3 || ^4"
+BuildRequires: phpunit7
+BuildRequires: php-symfony4-process
%endif
# from composer.json
-# "php": "^7.0"
-Requires: php(language) >= 7.0
-# from phpcompatinfo report for version 2.0.1
+# "php": "^7.1"
+Requires: php(language) >= 7.1
+# from phpcompatinfo report for version 3.0.0
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -106,6 +110,14 @@ exit $ret
%changelog
+* Fri Feb 2 2018 Remi Collet <remi@remirepo.net> - 3.0.0-0
+- update to 3.0.0
+- renamed to php-sebastian-diff3
+- move to /usr/share/php/SebastianBergmann/Diff3
+- raise dependency on PHP 7.1
+- use phpunit7
+- boostrap build
+
* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 2.0.1-1
- update to 2.0.1
- renamed to php-sebastian-diff2