summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-02-05 11:38:32 +0100
committerRemi Collet <remi@php.net>2024-02-05 11:38:32 +0100
commitef59a5f15318b426884ff2152f73adf5004f9874 (patch)
tree0b6a4b1beaeb476888adfc2ec3546aa8f57561b3
dup v3
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json43
-rwxr-xr-xmakesrc.sh35
-rw-r--r--php-sebastian-complexity4.spec161
5 files changed, 252 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..77001bb
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,43 @@
+{
+ "name": "sebastian/complexity",
+ "description": "Library for calculating the complexity of PHP code units",
+ "type": "library",
+ "homepage": "https://github.com/sebastianbergmann/complexity",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/complexity/issues",
+ "security": "https://github.com/sebastianbergmann/complexity/security/policy"
+ },
+ "prefer-stable": true,
+ "require": {
+ "php": ">=8.1",
+ "nikic/php-parser": "^4.18 || ^5.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^10.0"
+ },
+ "config": {
+ "platform": {
+ "php": "8.1.0"
+ },
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-main": "3.2-dev"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..b959795
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,35 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+DATE=$(sed -n '/^%global gh_date/{s/.* //;p}' $NAME.spec)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+DATE=$(date -d "$DATE -4 days" +%Y-%m-%d)
+
+if [ -f $NAME-$VERSION-$SHORT.tgz ]; then
+ echo "$NAME-$VERSION-$SHORT.tgz already there"
+else
+ echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Date=$DATE\n"
+
+ echo "Cloning..."
+ rm -rf $PROJECT-$COMMIT
+ git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
+
+ echo "Getting commit..."
+ pushd $PROJECT-$COMMIT
+ git checkout $COMMIT || exit1
+ cp composer.json ../composer.json
+ popd
+
+ echo "Archiving..."
+ tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+ echo "Cleaning..."
+ rm -rf $PROJECT-$COMMIT
+
+ echo "Done."
+fi
diff --git a/php-sebastian-complexity4.spec b/php-sebastian-complexity4.spec
new file mode 100644
index 0000000..ae31721
--- /dev/null
+++ b/php-sebastian-complexity4.spec
@@ -0,0 +1,161 @@
+# remirepo/fedora spec file for php-sebastian-complexity3
+#
+# Copyright (c) 2020-2023 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%bcond_without tests
+
+# github
+%global gh_commit 68ff824baeae169ec9f2137158ee529584553799
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project complexity
+# packagist
+%global pk_vendor sebastian
+%global pk_project %{gh_project}
+%global major 3
+# namespace
+%global php_home %{_datadir}/php
+%global ns_vendor SebastianBergmann
+%global ns_project Complexity
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 3.2.0
+Release: 1%{?dist}
+Summary: Calculating the complexity of PHP code units, version %{major}
+
+License: BSD-3-Clause
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snapshot to retrieve test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+BuildRequires: php(language) >= 8.1
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(nikic/php-parser) >= 4.18 with php-composer(nikic/php-parser) < 6)
+# remirepo:3
+%else
+BuildRequires: php-nikic-php-parser4 >= 4.18
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
+%if %{with tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^10.0"
+BuildRequires: phpunit10
+%endif
+
+# from composer.json, "require": {
+# "php": ">=8.1",
+# "nikic/php-parser": "^4.18 || ^5.0"
+Requires: php(language) >= 8.1
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(nikic/php-parser) >= 4.18 with php-composer(nikic/php-parser) < 6)
+# remirepo:3
+%else
+Requires: php-nikic-php-parser4 >= 4.18
+%endif
+# from phpcompatinfo report for version 3.0.0
+# none
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Library for calculating the complexity of PHP code units.
+
+This package provides version %{major} of %{pk_vendor}/%{pk_project} library.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+phpab --template fedora --output src/autoload.php src
+
+cat <<EOF | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ [
+ '%{php_home}/PhpParser5/autoload.php',
+ '%{php_home}/PhpParser4/autoload.php',
+ ],
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with tests}
+mkdir vendor
+touch vendor/autoload.php
+
+: Run upstream test suite
+ret=0
+for cmd in php php81 php82 php83; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit10 || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Thu Dec 21 2023 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0
+- raise dependency on nikic/php-parser 4.18 and allow 5.0
+
+* Thu Sep 28 2023 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+
+* Thu Aug 31 2023 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1
+
+* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 3.0.0-3
+- Enable test suite
+
+* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- raise dependency on PHP 8.1
+- raise dependency on nikic/php-parser 4.10
+- rename to php-sebastian-complexity3
+- move to /usr/share/php/SebastianBergmann/Complexity3
+
+* Tue Oct 27 2020 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- update to 2.0.2
+
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1 (no change)
+
+* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- initial package