summaryrefslogtreecommitdiffstats
path: root/php-sebastian-code-unit3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-code-unit3.spec')
-rw-r--r--php-sebastian-code-unit3.spec33
1 files changed, 20 insertions, 13 deletions
diff --git a/php-sebastian-code-unit3.spec b/php-sebastian-code-unit3.spec
index 2e42a22..997fe0d 100644
--- a/php-sebastian-code-unit3.spec
+++ b/php-sebastian-code-unit3.spec
@@ -1,31 +1,32 @@
-# remirepo/fedora spec file for php-sebastian-code-unit2
+# remirepo/fedora spec file for php-sebastian-code-unit3
#
-# Copyright (c) 2020-2023 Remi Collet
+# Copyright (c) 2020-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%bcond_without tests
+%bcond_with tests
# Sources
-%global gh_commit a81fee9eef0b7a76af11d121767abc44c104e503
+%global gh_commit 6634549cb8d702282a04a774e36a7477d2bd9015
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project code-unit
+%global gh_date 2024-02-02
# Packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
# Namespace
-%global major 2
+%global major 3
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project CodeUnit
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.0
-Release: 3%{?dist}
+Version: 3.0.0
+Release: 1%{?dist}
Summary: Collection of value objects that represent the PHP code units, version %{major}
License: BSD-3-Clause
@@ -34,20 +35,20 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.1
+BuildRequires: php(language) >= 8.2
BuildRequires: php-reflection
BuildRequires: php-spl
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^10.0"
-BuildRequires: phpunit10
+# "phpunit/phpunit": "^11.0"
+BuildRequires: phpunit11
%endif
# from composer.json, "require": {
-# "php": ">=8.1"
-Requires: php(language) >= 8.1
+# "php": ">=8.2"
+Requires: php(language) >= 8.2
# From phpcompatinfo report for 2.0.0
Requires: php-reflection
Requires: php-spl
@@ -101,7 +102,7 @@ EOF
: Run tests
ret=0
-for cmd in php php81 php82 php83; do
+for cmd in php php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit10 --bootstrap vendor/autoload.php || ret=1
@@ -121,6 +122,12 @@ exit $ret
%changelog
+* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- raise dependency on PHP 8.2
+- rename to php-sebastian-code-unit3
+- move to /usr/share/php/SebastianBergmann/CodeUnit3
+
* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 2.0.0-3
- Enable test suite