summaryrefslogtreecommitdiffstats
path: root/php-sebastian-cli-parser3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-cli-parser3.spec')
-rw-r--r--php-sebastian-cli-parser3.spec33
1 files changed, 20 insertions, 13 deletions
diff --git a/php-sebastian-cli-parser3.spec b/php-sebastian-cli-parser3.spec
index dfcfa91..f50c2f9 100644
--- a/php-sebastian-cli-parser3.spec
+++ b/php-sebastian-cli-parser3.spec
@@ -1,31 +1,32 @@
-# remirepo/fedora spec file for php-sebastian-cli-parser2
+# remirepo/fedora spec file for php-sebastian-cli-parser3
#
-# Copyright (c) 2020-2023 Remi Collet
+# Copyright (c) 2020-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%bcond_without tests
+%bcond_with tests
# github
-%global gh_commit efdc130dbbbb8ef0b545a994fd811725c5282cae
+%global gh_commit efd6ce5bb8131fe981e2f879dbd47605fbe0cc6f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project cli-parser
+%global gh_date 2024-02-02
# packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
-%global major 2
+%global major 3
# namespace
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project CliParser
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.0
-Release: 3%{?dist}
+Version: 3.0.0
+Release: 1%{?dist}
Summary: Library for parsing CLI options, version %{major}
License: BSD-3-Clause
@@ -35,20 +36,20 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.1
+BuildRequires: php(language) >= 8.2
BuildRequires: php-pcre
BuildRequires: php-spl
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^10.0"
-BuildRequires: phpunit10
+# "phpunit/phpunit": "^11.0"
+BuildRequires: phpunit11
%endif
# from composer.json, "require": {
-# "php": ">=8.1",
-Requires: php(language) >= 8.1
+# "php": ">=8.2",
+Requires: php(language) >= 8.2
# from phpcompatinfo report for version 2.0.0
Requires: php-pcre
Requires: php-spl
@@ -87,7 +88,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php81 php82 php83; do
+for cmd in php php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit10 || ret=1
@@ -110,6 +111,12 @@ exit $ret
%changelog
+* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- raise dependency on PHP 8.2
+- rename to php-sebastian-cli-parser2
+- move to /usr/share/php/SebastianBergmann/CliParser3
+
* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 2.0.0-3
- Enable test suite