summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-21 08:40:50 +0200
committerRemi Collet <remi@remirepo.net>2017-08-21 08:40:50 +0200
commitdce02015c3107d02cffd7f2f465d2cc1ebd600e3 (patch)
tree851dbe83d64607d635d05c312e6fb15f38ef6e9f
New package
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json64
-rw-r--r--php-phpunit-selenium.spec233
4 files changed, 308 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..1371ffe
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,64 @@
+{
+ "name": "phpunit/phpunit-selenium",
+ "description": "Selenium Server integration for PHPUnit",
+ "type": "library",
+ "keywords": [
+ "xunit",
+ "phpunit",
+ "testing",
+ "selenium"
+ ],
+ "homepage": "http://www.phpunit.de/",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Giorgio Sironi",
+ "email": "info@giorgiosironi.com",
+ "role": "developer"
+ },
+ {
+ "name": "Ivan Kurnosov",
+ "email": "zerkms@zerkms.com",
+ "role": "developer"
+ },
+ {
+ "name": "Paul Briton",
+ "role": "developer"
+ },
+ {
+ "name": "Patrik Štrba",
+ "role": "developer"
+ },
+ {
+ "name": "Petr Kotek",
+ "role": "developer"
+ },
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sb@sebastian-bergmann.de",
+ "role": "original developer"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/phpunit-selenium/issues",
+ "irc": "irc://irc.freenode.net/phpunit"
+ },
+ "require": {
+ "php": ">=7.0",
+ "phpunit/phpunit": ">=6.0,<7.0",
+ "sebastian/comparator": "~1.0",
+ "ext-curl": "*",
+ "ext-dom": "*"
+ },
+ "require-dev": {
+ "phing/phing": "2.*"
+ },
+ "autoload": {
+ "classmap": [
+ "PHPUnit/"
+ ]
+ },
+ "include-path": [
+ ""
+ ]
+}
diff --git a/php-phpunit-selenium.spec b/php-phpunit-selenium.spec
new file mode 100644
index 0000000..200c8fc
--- /dev/null
+++ b/php-phpunit-selenium.spec
@@ -0,0 +1,233 @@
+# remirepo/fedora spec file for php-phpunit-selenium
+#
+# Copyright (c) 2010-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 87b7b0a353fe9c956485b34484f7ce766db8e120
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner giorgiosironi
+%global gh_project phpunit-selenium
+%global pk_vendor phpunit
+%global pk_project %{gh_project}
+%global php_home %{_datadir}/php/PHPUnit6
+# No test, as test suite requires a Selenium server
+
+Name: php-%{pk_project}
+Version: 4.0.0
+Release: 1%{?dist}
+Summary: Selenium RC integration for PHPUnit
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+BuildRequires: php(language) >= 7.0
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer.json
+# "php": ">=7.0",
+# "phpunit/phpunit": ">=6.0,<7.0",
+# "sebastian/comparator": "~1.0",
+# "ext-curl": "*",
+# "ext-dom": "*"
+Requires: php(language) >= 7.0
+Requires: phpunit6
+Requires: php-curl
+Requires: php-dom
+# https://github.com/giorgiosironi/phpunit-selenium/issues/412
+# => ignore everything already required by PHPUnit
+# From phpcompatinfo report for version 4.0.0
+Requires: php-date
+Requires: php-json
+Requires: php-pcre
+Requires: php-reflection
+Requires: php-spl
+Requires: php-zip
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+
+%description
+This package contains a Selenium2TestCase class that can be used to run
+end-to-end tests against Selenium 2.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+rm PHPUnit/Extensions/SeleniumCommon/Autoload.php.in
+
+
+%build
+# Regenerate Autoloader as upstream one is outdated
+%{_bindir}/phpab \
+ --template fedora \
+ --output PHPUnit/Extensions/SeleniumCommon/Autoload.php \
+ PHPUnit
+
+
+%install
+mkdir -p %{buildroot}%{php_home}
+cp -pr PHPUnit/* %{buildroot}%{php_home}
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc ChangeLog.markdown README.md
+%doc composer.json
+%{php_home}/Extensions/Selenium*
+
+
+%changelog
+* Mon Aug 21 2017 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- update to 4.0.0 for phpunit6
+- rename to php-phpunit-selenium
+- raise dependency on PHP 7.0
+
+* Tue Jan 24 2017 Remi Collet <remi@fedoraproject.org> - 3.0.3-1
+- update to 3.0.3
+- switch to fedora/autoloader
+
+* Fri Apr 22 2016 Remi Collet <remi@fedoraproject.org> - 3.0.2-1
+- update to 3.0.2
+
+* Tue Mar 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
+- update to 3.0.1
+
+* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
+- update to 3.0.0
+- raise dependency on PHPUnit >= 5
+- raise dependency on PHP >= 5.6
+
+* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- update to 2.0.1
+- only support PHP 5
+
+* Fri Jan 29 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
+- fix autoloader
+
+* Mon Jan 4 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0
+- raise dependency on PHPUnit >=4.8,<=6.0
+
+* Sun Nov 2 2014 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
+- Update to 1.4.2
+- fix license handling
+
+* Tue Aug 19 2014 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
+- Update to 1.4.1
+- add dependency on sebastian/comparator
+
+* Mon Aug 4 2014 Remi Collet <remi@fedoraproject.org> - 1.4.0-1
+- Update to 1.4.0
+- composer dependencies
+
+* Wed Apr 30 2014 Remi Collet <remi@fedoraproject.org> - 1.3.3-3
+- cleanup pear registry
+
+* Tue Apr 29 2014 Remi Collet <remi@fedoraproject.org> - 1.3.3-2
+- sources from github
+
+* Fri Nov 22 2013 Remi Collet <remi@fedoraproject.org> - 1.3.3-1
+- Update to 1.3.3 (stable)
+- improve description
+
+* Mon Aug 26 2013 Remi Collet <remi@fedoraproject.org> - 1.3.2-1
+- Update to 1.3.2
+
+* Mon Jun 03 2013 Remi Collet <remi@fedoraproject.org> - 1.3.1-1
+- Update to 1.3.1
+
+* Mon May 06 2013 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- Update to 1.3.0
+
+* Mon Feb 04 2013 Remi Collet <remi@fedoraproject.org> - 1.2.12-1
+- Version 1.2.12 (stable) - API 1.2.1 (stable)
+
+* Mon Dec 10 2012 Remi Collet <remi@fedoraproject.org> - 1.2.11-1
+- Version 1.2.11 (stable) - API 1.2.1 (stable)
+
+* Mon Oct 22 2012 Remi Collet <remi@fedoraproject.org> - 1.2.10-1
+- Version 1.2.10 (stable) - API 1.2.1 (stable)
+
+* Sat Sep 29 2012 Remi Collet <remi@fedoraproject.org> - 1.2.9-1
+- Version 1.2.9 (stable) - API 1.2.1 (stable)
+- raise dependencies: php 5.3.3, PHPUnit 3.7.0
+
+* Thu Aug 9 2012 Remi Collet <remi@fedoraproject.org> - 1.2.8-1
+- Version 1.2.8 (stable) - API 1.2.1 (stable)
+
+* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.7-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Thu Jun 07 2012 Remi Collet <remi@fedoraproject.org> - 1.2.7-1
+- Version 1.2.7 (stable) - API 1.2.1 (stable)
+
+* Sun Apr 01 2012 Remi Collet <remi@fedoraproject.org> - 1.2.6-1
+- Version 1.2.6 (stable) - API 1.2.1 (stable)
+
+* Sat Mar 17 2012 Remi Collet <remi@fedoraproject.org> - 1.2.5-1
+- Version 1.2.5 (stable) - API 1.2.1 (stable)
+
+* Mon Mar 12 2012 Remi Collet <remi@fedoraproject.org> - 1.2.4-1
+- Version 1.2.4 (stable) - API 1.2.1 (stable)
+
+* Fri Feb 17 2012 Remi Collet <remi@fedoraproject.org> - 1.2.3-1
+- Version 1.2.3 (stable) - API 1.2.1 (stable)
+
+* Mon Jan 23 2012 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
+- Version 1.2.1 (stable) - API 1.2.1 (stable)
+- add Selenium2TestCase extension
+
+* Mon Jan 16 2012 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- Version 1.2.0 (stable) - API 1.2.0 (stable)
+
+* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Mon Dec 19 2011 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
+- Version 1.1.3 (stable) - API 1.1.0 (stable)
+
+* Mon Dec 12 2011 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
+- Version 1.1.2 (stable) - API 1.1.0 (stable)
+
+* Wed Nov 30 2011 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- Version 1.1.1 (stable) - API 1.1.0 (stable)
+
+* Tue Nov 01 2011 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- Version 1.1.0 (stable) - API 1.1.0 (stable)
+
+* Fri Jun 10 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.3-1
+- Version 1.0.3 (stable) - API 1.0.0 (stable)
+- remove PEAR hack (only needed for EPEL)
+- raise PEAR dependency to 1.9.2
+
+* Tue May 3 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.2-3
+- rebuild for doc in /usr/share/doc/pear
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Tue Jan 18 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.2-1
+- Version 1.0.2 (stable) - API 1.0.0 (stable)
+- CHANGELOG and LICENSE are now in the tarball
+
+* Wed Nov 17 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.1-1
+- Version 1.0.1 (stable) - API 1.0.0 (stable)
+
+* Fri Nov 05 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-2
+- lower PEAR dependency to allow el6 build
+- fix URL
+
+* Sun Sep 26 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-1
+- initial generated spec + clean
+