summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-09 11:14:00 +0100
committerRemi Collet <remi@remirepo.net>2020-12-09 11:14:00 +0100
commit7d9e334434df539edb8ec91e66b026e24685a936 (patch)
treed216130dbc3e298f01f0484871178fc07603a1ec
parentb421e7c888d409a09f91c4a018c01531e5442701 (diff)
update to 9.0.0
raise dependency on PHP 7.3 switch from PHPUnit 8 to 9
-rw-r--r--.gitignore2
-rw-r--r--composer.json4
-rw-r--r--php-phpunit-selenium.spec25
3 files changed, 19 insertions, 12 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index 41f1af4..dc2c6d0 100644
--- a/composer.json
+++ b/composer.json
@@ -43,9 +43,9 @@
"issues": "https://github.com/giorgiosironi/phpunit-selenium/issues"
},
"require": {
- "php": ">=7.2",
+ "php": ">=7.3",
"ext-curl": "*",
- "phpunit/phpunit": ">=8.0,<9.0"
+ "phpunit/phpunit": ">=9.0,<10.0"
},
"require-dev": {
"phing/phing": "2.*"
diff --git a/php-phpunit-selenium.spec b/php-phpunit-selenium.spec
index 266641f..3da66b0 100644
--- a/php-phpunit-selenium.spec
+++ b/php-phpunit-selenium.spec
@@ -6,36 +6,36 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 7c8bef67f1e206044bbb8e873402c696611ada43
+%global gh_commit 41711edd4dfcc5a0db2f8a22da6d2ddc908da741
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner giorgiosironi
%global gh_project phpunit-selenium
%global pk_vendor phpunit
%global pk_project %{gh_project}
-%global php_home %{_datadir}/php/PHPUnit8
+%global php_home %{_datadir}/php/PHPUnit9
# No test, as test suite requires a Selenium server
Name: php-%{pk_project}
-Version: 8.0.0
+Version: 9.0.0
Release: 1%{?dist}
-Summary: Selenium RC integration for PHPUnit
+Summary: Selenium RC integration for PHPUnit 9
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
BuildArch: noarch
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
# From composer.json
-# "php": ">=7.1",
+# "php": ">=7.3",
# "ext-curl": "*"
-# "phpunit/phpunit": ">=8.0,<9.0",
-Requires: php(language) >= 7.2
+# "phpunit/phpunit": ">=9.0,<10.0",
+Requires: php(language) >= 7.3
Requires: php-curl
-Requires: phpunit8
-# From phpcompatinfo report for version 8.0.0
+Requires: phpunit9
+# From phpcompatinfo report for version 9.0.0
Requires: php-date
Requires: php-json
Requires: php-pcre
@@ -83,6 +83,11 @@ cp -pr PHPUnit/* %{buildroot}%{php_home}
%changelog
+* Wed Dec 9 2020 Remi Collet <remi@remirepo.net> - 9.0.0-1
+- update to 9.0.0
+- raise dependency on PHP 7.3
+- switch from PHPUnit 8 to 9
+
* Tue Mar 17 2020 Remi Collet <remi@remirepo.net> - 8.0.0-1
- update to 8.0.0
- raise dependency on PHP 7.2