summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phpunit-php-token-stream4.spec30
1 files changed, 24 insertions, 6 deletions
diff --git a/php-phpunit-php-token-stream4.spec b/php-phpunit-php-token-stream4.spec
index 8baec60..19136c3 100644
--- a/php-phpunit-php-token-stream4.spec
+++ b/php-phpunit-php-token-stream4.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-php-token-stream4
#
-# Copyright (c) 2010-2020 Christof Damian, Remi Collet
+# Copyright (c) 2010-2023 Christof Damian, Remi Collet
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5672711b6b07b14d5ab694e700c62eeb82fcf374
+%global gh_commit a853a0e183b9db7eed023d7933a858fa1c8d25a3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-token-stream
@@ -26,11 +26,11 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.3
-Release: 1%{?dist}
+Version: 4.0.4
+Release: 8%{?dist}
Summary: Wrapper around PHP tokenizer extension
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -70,6 +70,15 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+cat << 'EOF' | tee -a src/NewTokens.php
+<?php declare(strict_types=1);
+
+// From PHP 8.1
+class PHP_Token_AMPERSAND_FOLLOWED_BY_VAR_OR_VARARG extends PHP_Token
+{
+}
+EOF
+
%build
# Generate the Autoloader
@@ -88,7 +97,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit9 --verbose || ret=1
@@ -111,6 +120,15 @@ exit $ret
%changelog
+* Thu Apr 20 2023 Remi Collet <remi@remirepo.net> - 4.0.4-8
+- use SPDX license ID
+
+* Thu Nov 4 2021 Remi Collet <remi@remirepo.net> - 4.0.4-4
+- add missing token from PHP 8.1
+
+* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 4.0.4-1
+- update to 4.0.4
+
* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 4.0.3-1
- update to 4.0.3