summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-16 10:10:22 +0200
committerRemi Collet <remi@remirepo.net>2020-06-16 10:10:22 +0200
commit4658bb7dde9ae91b974d6a86ef04f12e5c12b8bc (patch)
treed15ce61a9cc3217416dfb6416e5ca629ed9b2dbd
parentad57c466ad432961dbd64e9f0c7c0538c71acd67 (diff)
update to 4.0.2
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-phpunit-php-token-stream4.spec22
2 files changed, 43 insertions, 7 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..4190c13
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-phpunit-php-token-stream4.spec b/php-phpunit-php-token-stream4.spec
index 0586edb..74cf592 100644
--- a/php-phpunit-php-token-stream4.spec
+++ b/php-phpunit-php-token-stream4.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b2560a0c33f7710e4d7f8780964193e8e8f8effe
+%global gh_commit e61c593e9734b47ef462340c24fca8d6a57da14e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-token-stream
@@ -26,13 +26,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.0
+Version: 4.0.2
Release: 1%{?dist}
Summary: Wrapper around PHP tokenizer extension
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
@@ -43,8 +44,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.0"
-# TODO test suite passes with v8, switch to v9 when available
-BuildRequires: phpunit8
+BuildRequires: phpunit9
%endif
# from composer.json
@@ -88,10 +88,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit8 --verbose || ret=1
+ %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -111,6 +111,14 @@ exit $ret
%changelog
+* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 4.0.2-1
+- update to 4.0.2
+
+* Wed May 6 2020 Remi Collet <remi@remirepo.net> - 4.0.1-1
+- update to 4.0.1
+- sources from git snapshot
+- switch to phpunit9
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 4.0.0-1
- update to 4.0.0
- raise dependency on PHP 7.3