summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-phpunit-php-token-stream3.spec11
2 files changed, 8 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index f50e937..afaabac 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,7 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.1",
+ "php": ">=7.1",
"ext-tokenizer": "*"
},
"require-dev": {
diff --git a/php-phpunit-php-token-stream3.spec b/php-phpunit-php-token-stream3.spec
index eca263f..73fc4c9 100644
--- a/php-phpunit-php-token-stream3.spec
+++ b/php-phpunit-php-token-stream3.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 995192df77f63a59e47f025390d2d1fdf8f425ff
+%global gh_commit 472b687829041c24b25f475e14c2f38a09edf1c2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-token-stream
@@ -26,7 +26,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.1.1
+Version: 3.1.2
Release: 1%{?dist}
Summary: Wrapper around PHP tokenizer extension
@@ -47,7 +47,7 @@ BuildRequires: php-spl
%endif
# from composer.json
-# "php": "^7.1",
+# "php": ">=7.1",
# "ext-tokenizer": "*"
Requires: php(language) >= 7.1
Requires: php-tokenizer
@@ -87,7 +87,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit7 --verbose || ret=1
@@ -110,6 +110,9 @@ exit $ret
%changelog
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2 (no change)
+
* Tue Sep 17 2019 Remi Collet <remi@remirepo.net> - 3.1.1-1
- update to 3.1.1