summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-token-stream2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-token-stream2.spec')
-rw-r--r--php-phpunit-php-token-stream2.spec32
1 files changed, 24 insertions, 8 deletions
diff --git a/php-phpunit-php-token-stream2.spec b/php-phpunit-php-token-stream2.spec
index a0e6d04..593762d 100644
--- a/php-phpunit-php-token-stream2.spec
+++ b/php-phpunit-php-token-stream2.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-php-token-stream2
#
-# Copyright (c) 2010-2015 Christof Damian, Remi Collet
+# Copyright (c) 2010-2021 Christof Damian, Remi Collet
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9a02332089ac48e704c70f6cefed30c224e3c0b0
+%global gh_commit 791198a2c6254db10131eecfe8c06670700904db
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-token-stream
@@ -26,11 +26,10 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.1
-Release: 1%{?dist}
+Version: 2.0.2
+Release: 8%{?dist}
Summary: Wrapper around PHP tokenizer extension
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
@@ -42,7 +41,7 @@ BuildRequires: php(language) >= 7.0
BuildRequires: php-tokenizer
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^6.2.4"
-BuildRequires: phpunit6 >= 6.2.4
+BuildRequires: phpunit
BuildRequires: php-pcre
BuildRequires: php-spl
%endif
@@ -70,6 +69,16 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+cat << 'EOF' | tee -a src/Token.php
+
+class PHP_Token_NAME_QUALIFIED extends PHP_Token
+{
+}
+
+class PHP_Token_NAME_FULLY_QUALIFIED extends PHP_Token
+{
+}
+EOF
%build
# Generate the Autoloader
@@ -88,10 +97,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit6 --verbose || ret=1
+ %{_bindir}/phpunit --verbose || ret=1
fi
done
exit $ret
@@ -110,6 +119,13 @@ exit $ret
%changelog
+* Thu Mar 18 2021 Remi Collet <remi@remirepo.net> - 2.0.2-8
+- add missing token from PHP 8
+- switch back to phpunit
+
+* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- Update to 2.0.2
+
* Mon Nov 6 2017 Remi Collet <remi@remirepo.net> - 2.0.1-1
- rename to php-phpunit-php-token-stream2