summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--php-phpunit-php-timer8.spec38
2 files changed, 25 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index f4991e4..89c3984 100644
--- a/composer.json
+++ b/composer.json
@@ -20,14 +20,14 @@
},
"prefer-stable": true,
"require": {
- "php": ">=8.2"
+ "php": ">=8.3"
},
"require-dev": {
- "phpunit/phpunit": "^11.0"
+ "phpunit/phpunit": "^12.0"
},
"config": {
"platform": {
- "php": "8.2.0"
+ "php": "8.3.0"
},
"optimize-autoloader": true,
"sort-packages": true
@@ -39,7 +39,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "7.0-dev"
+ "dev-main": "8.0-dev"
}
}
}
diff --git a/php-phpunit-php-timer8.spec b/php-phpunit-php-timer8.spec
index d98a4ef..014dd50 100644
--- a/php-phpunit-php-timer8.spec
+++ b/php-phpunit-php-timer8.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for php-phpunit-php-timer7
+# remirepo/fedora spec file for php-phpunit-php-timer8
#
# Copyright (c) 2010-2025 Christof Damian, Remi Collet
#
@@ -8,14 +8,14 @@
# Please, preserve the changelog entries
#
-# disabled until phpunit11 available
-%bcond_without tests
+# disabled until phpunit12 available
+%bcond_with tests
-%global gh_commit 3b415def83fbcb41f991d9ebf16ae4ad8b7837b3
+%global gh_commit f258ce36aa457f3aa3339f9ed4c81fc66dc8c2cc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
-%global gh_date 2024-07-03
+%global gh_date 2025-02-07
# Packagist
%global pk_vendor phpunit
%global pk_project %{gh_project}
@@ -23,12 +23,12 @@
%global ns_vendor SebastianBergmann
%global ns_project Timer
-%global major 7
+%global major 8
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 7.0.1
-Release: 2%{?dist}
+Version: 8.0.0
+Release: 1%{?dist}
Summary: PHP Utility class for timing, version %{major}
License: BSD-3-Clause
@@ -38,20 +38,18 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.2
-BuildRequires: php-spl
+BuildRequires: php(language) >= 8.3
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json"require-dev": {
-# "phpunit/phpunit": "^11.0"
-BuildRequires: phpunit11
+# "phpunit/phpunit": "^12.0"
+BuildRequires: phpunit12
%endif
# From composer.json
-# "php": ">=8.2"
-Requires: php(language) >= 8.2
+# "php": ">=8.3"
+Requires: php(language) >= 8.3
# From phpcompatinfo report for version 6.0.0
-Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -90,10 +88,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php82 php83 php84; do
+for cmd in php php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit11 || ret=1
+ %{_bindir}/phpunit12 || ret=1
fi
done
exit $ret
@@ -109,6 +107,12 @@ exit $ret
%changelog
+* Fri Feb 7 2025 Remi Collet <remi@remirepo.net> - 8.0.0-1
+- update to 8.0.0
+- raise dependency on PHP 8.3
+- rename to php-phpunit-php-timer8
+- move to /usr/share/php/SebastianBergmann/Timer8
+
* Tue Feb 4 2025 Remi Collet <remi@remirepo.net> - 7.0.1-2
- enable test suite