summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-03 14:04:09 +0200
committerRemi Collet <remi@php.net>2024-07-03 14:04:09 +0200
commit416492abddfb62d0032b6432b21b646dbdf41e41 (patch)
tree9748f451b4f22a631a2ff2b6baf84348666714a8
parentce120eac63a4e37bdaf1d73bec75bd39f8755ca8 (diff)
update to 7.0.1HEADmaster
-rw-r--r--php-phpunit-php-timer7.spec14
1 files changed, 8 insertions, 6 deletions
diff --git a/php-phpunit-php-timer7.spec b/php-phpunit-php-timer7.spec
index 9ec15f4..fb804c7 100644
--- a/php-phpunit-php-timer7.spec
+++ b/php-phpunit-php-timer7.spec
@@ -11,11 +11,11 @@
# disabled until phpunit11 available
%bcond_with tests
-%global gh_commit 8a59d9e25720482ee7fcdf296595e08795b84dc5
+%global gh_commit 3b415def83fbcb41f991d9ebf16ae4ad8b7837b3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
-%global gh_date 2024-02-02
+%global gh_date 2024-07-03
# Packagist
%global pk_vendor phpunit
%global pk_project %{gh_project}
@@ -27,12 +27,13 @@
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 7.0.0
+Version: 7.0.1
Release: 1%{?dist}
Summary: PHP Utility class for timing, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
+# run makesrc.sh to create a git snapshot with test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -89,7 +90,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php82 php83; do
+for cmd in php php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit11 || ret=1
@@ -100,8 +101,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md
%doc composer.json
@@ -110,6 +109,9 @@ exit $ret
%changelog
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 7.0.1-1
+- update to 7.0.1
+
* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 7.0.0-1
- update to 7.0.0
- raise dependency on PHP 8.2