summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-timer5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-timer5.spec')
-rw-r--r--php-phpunit-php-timer5.spec8
1 files changed, 7 insertions, 1 deletions
diff --git a/php-phpunit-php-timer5.spec b/php-phpunit-php-timer5.spec
index 1d9fcae..60dc025 100644
--- a/php-phpunit-php-timer5.spec
+++ b/php-phpunit-php-timer5.spec
@@ -84,7 +84,11 @@ ret=0
for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit9 --verbose || ret=1
+ %{_bindir}/phpunit9 \
+%if %{__isa_bits} < 64
+ --filter '^((?!(testCanBeFormattedAsString)).)*$' \
+%endif
+ --verbose || ret=1
fi
done
exit $ret
@@ -104,6 +108,8 @@ exit $ret
%changelog
* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 5.0.3-1
- update to 5.0.3
+- open https://github.com/sebastianbergmann/php-timer/issues/34
+ 32-bit compatibility
* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 5.0.2-1
- update to 5.0.2 (no change)