summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-timer5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-timer5.spec')
-rw-r--r--php-phpunit-php-timer5.spec26
1 files changed, 18 insertions, 8 deletions
diff --git a/php-phpunit-php-timer5.spec b/php-phpunit-php-timer5.spec
index 2697b6d..a6e3bd6 100644
--- a/php-phpunit-php-timer5.spec
+++ b/php-phpunit-php-timer5.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-php-timer4
#
-# Copyright (c) 2010-2020 Christof Damian, Remi Collet
+# Copyright (c) 2010-2023 Christof Damian, Remi Collet
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -25,14 +25,16 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 5.0.3
-Release: 1%{?dist}
+Release: 7%{?dist}
Summary: PHP Utility class for timing, version %{major}
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/sebastianbergmann/php-timer/pull/36.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
@@ -57,9 +59,14 @@ Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
Utility class for timing things, factored out of PHPUnit into a stand-alone
component.
+This package provides version %{major} of %{pk_vendor}/%{pk_project} library.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
%build
@@ -81,14 +88,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-if [ $(php -r 'echo PHP_INT_SIZE;') -lt 8 ]; then
- filter="--filter '^((?!(testCanBeFormattedAsString)).)*$'"
-fi
-for cmd in php php73 php74 php80; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit9 \
- $filter \
--verbose || ret=1
fi
done
@@ -107,6 +110,13 @@ exit $ret
%changelog
+* Fri Apr 21 2023 Remi Collet <remi@remirepo.net> - 5.0.3-7
+- use SPDX License id
+
+* Tue Oct 27 2020 Remi Collet <remi@remirepo.net> - 5.0.3-2
+- add patch for test suite on 32-bit from
+ https://github.com/sebastianbergmann/php-timer/pull/36
+
* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 5.0.3-1
- update to 5.0.3
- open https://github.com/sebastianbergmann/php-timer/issues/34