summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-phpunit-php-timer5.spec17
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 74a172d..98a7934 100644
--- a/composer.json
+++ b/composer.json
@@ -19,7 +19,7 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3"
+ "php": "^7.3 || ^8.0"
},
"require-dev": {
"phpunit/phpunit": "^9.2"
diff --git a/php-phpunit-php-timer5.spec b/php-phpunit-php-timer5.spec
index eedf473..8654384 100644
--- a/php-phpunit-php-timer5.spec
+++ b/php-phpunit-php-timer5.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 1
-%global gh_commit b0d089de001ba60ffa3be36b23e1b8150d072238
+%global gh_commit cc49734779cbb302bf51a44297dab8c4bbf941e7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
@@ -22,13 +22,13 @@
%global major 5
%global php_home %{_datadir}/php
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.0.0
+Version: 5.0.1
Release: 1%{?dist}
Summary: PHP Utility class for timing
@@ -40,14 +40,14 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# From composer.json"require-dev": {
# "phpunit/phpunit": "^9.2"
BuildRequires: phpunit9 >= 9.2
%endif
# From composer.json
-# "php": "^7.3"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# From phpcompatinfo report for version 4.0.0
Requires: php-spl
@@ -78,7 +78,7 @@ mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
-%if %{with_tests}
+%if %{with tests}
%check
mkdir vendor
touch vendor/autoload.php
@@ -106,6 +106,9 @@ exit $ret
%changelog
+* Fri Jun 26 2020 Remi Collet <remi@remirepo.net> - 5.0.1-1
+- update to 5.0.1
+
* Mon Jun 8 2020 Remi Collet <remi@remirepo.net> - 5.0.0-1
- update to 5.0.0
- rename to php-phpunit-php-timer5