summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-28 09:43:41 +0200
committerRemi Collet <remi@remirepo.net>2020-09-28 09:43:41 +0200
commit82ccea856db1a5de4dad9822638adf58cf109d59 (patch)
tree9115ddd1ef2da762901f12442658fb7882354281
parentf28a6ba9369c4ed324a8b1956a93b13f1358e427 (diff)
update to 5.0.2 (no change)
-rw-r--r--composer.json4
-rw-r--r--php-phpunit-php-timer5.spec21
2 files changed, 12 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 98a7934..001701c 100644
--- a/composer.json
+++ b/composer.json
@@ -19,10 +19,10 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3 || ^8.0"
+ "php": ">=7.3"
},
"require-dev": {
- "phpunit/phpunit": "^9.2"
+ "phpunit/phpunit": "^9.3"
},
"config": {
"platform": {
diff --git a/php-phpunit-php-timer5.spec b/php-phpunit-php-timer5.spec
index 8654384..aaa446e 100644
--- a/php-phpunit-php-timer5.spec
+++ b/php-phpunit-php-timer5.spec
@@ -7,8 +7,9 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 1
-%global gh_commit cc49734779cbb302bf51a44297dab8c4bbf941e7
+%bcond_without tests
+
+%global gh_commit c9ff14f493699e2f6adee9fd06a0245b276643b7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
@@ -21,14 +22,9 @@
%global major 5
%global php_home %{_datadir}/php
-%if %{bootstrap}
-%bcond_with tests
-%else
-%bcond_without tests
-%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.0.1
+Version: 5.0.2
Release: 1%{?dist}
Summary: PHP Utility class for timing
@@ -42,12 +38,12 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json"require-dev": {
-# "phpunit/phpunit": "^9.2"
-BuildRequires: phpunit9 >= 9.2
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
%endif
# From composer.json
-# "php": "^7.3 || ^8.0"
+# "php": ">=7.3"
Requires: php(language) >= 7.3
# From phpcompatinfo report for version 4.0.0
Requires: php-spl
@@ -106,6 +102,9 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 5.0.2-1
+- update to 5.0.2 (no change)
+
* Fri Jun 26 2020 Remi Collet <remi@remirepo.net> - 5.0.1-1
- update to 5.0.1