summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-text-template5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-text-template5.spec')
-rw-r--r--php-phpunit-php-text-template5.spec38
1 files changed, 21 insertions, 17 deletions
diff --git a/php-phpunit-php-text-template5.spec b/php-phpunit-php-text-template5.spec
index 2f60045..d36491b 100644
--- a/php-phpunit-php-text-template5.spec
+++ b/php-phpunit-php-text-template5.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for php-phpunit-php-text-template4
+# remirepo/fedora spec file for php-phpunit-php-text-template5
#
# SPDX-FileCopyrightText: Copyright 2010-2025 Remi Collet
# SPDX-License-Identifier: CECILL-2.1
@@ -7,14 +7,14 @@
# Please, preserve the changelog entries
#
-# disabled until phpunit11 available
-%bcond_without tests
+# disabled until phpunit12 available
+%bcond_with tests
-%global gh_commit 3e0404dc6b300e6bf56415467ebcb3fe4f33e964
+%global gh_commit e1367a453f0eda562eedb4f659e13aa900d66c53
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-text-template
-%global gh_date 2024-07-03
+%global gh_date 2025-02-07
# Packagist
%global pk_vendor phpunit
%global pk_project %{gh_project}
@@ -22,11 +22,11 @@
%global ns_vendor SebastianBergmann
%global ns_project Template
%global php_home %{_datadir}/php
-%global ver_major 4
+%global ver_major 5
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 4.0.1
-Release: 2%{?dist}
+Version: 5.0.0
+Release: 1%{?dist}
Summary: Simple template engine, version %{ver_major}
License: BSD-3-Clause
@@ -36,20 +36,18 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.2
-BuildRequires: php-spl
+BuildRequires: php(language) >= 8.3
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json, require-dev
-# "phpunit/phpunit": "^11.0"
-BuildRequires: phpunit11
+# "phpunit/phpunit": "^12.0"
+BuildRequires: phpunit12
%endif
# From composer.json
-# "php": ">=8.2"
-Requires: php(language) >= 8.2
+# "php": ">=8.3"
+Requires: php(language) >= 8.3
# From phpcompatinfo report for version 3.0.0
-Requires: php-spl
Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
@@ -84,10 +82,10 @@ mkdir vendor
: Run upstream test suite
ret=0
-for cmd in php php82 php83 php84; do
+for cmd in php php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php \
- %{_bindir}/phpunit11 || ret=1
+ %{_bindir}/phpunit12 || ret=1
fi
done
exit $ret
@@ -103,6 +101,12 @@ exit $ret
%changelog
+* Fri Feb 7 2025 Remi Collet <remi@remirepo.net> - 5.0.0-1
+- update to 5.0.0
+- raise dependency on PHP 8.3
+- rename to php-phpunit-php-text-template5
+- move to /usr/share/php/SebastianBergmann/Template5
+
* Tue Feb 4 2025 Remi Collet <remi@remirepo.net> - 4.0.1-2
- enable test suite