summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-02-05 10:04:52 +0100
committerRemi Collet <remi@php.net>2024-02-05 10:04:52 +0100
commitabd876cfc62b188a6e0addaa680af02354d5284e (patch)
tree3d7ac9b6e4e25f9fab52054553da9427d92dbf02
parent74b17bcfa8352647360ef4f1298a10b8344d2a82 (diff)
update to 4.0.0
raise dependency on PHP 8.2 rename to php-phpunit-php-text-template4 move to /usr/share/php/SebastianBergmann/Template4
-rw-r--r--composer.json8
-rw-r--r--php-phpunit-php-text-template4.spec29
2 files changed, 22 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index cd6cf75..0f47249 100644
--- a/composer.json
+++ b/composer.json
@@ -20,17 +20,17 @@
},
"config": {
"platform": {
- "php": "8.1.0"
+ "php": "8.2.0"
},
"optimize-autoloader": true,
"sort-packages": true
},
"prefer-stable": true,
"require": {
- "php": ">=8.1"
+ "php": ">=8.2"
},
"require-dev": {
- "phpunit/phpunit": "^10.0"
+ "phpunit/phpunit": "^11.0"
},
"autoload": {
"classmap": [
@@ -39,7 +39,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "3.0-dev"
+ "dev-main": "4.0-dev"
}
}
}
diff --git a/php-phpunit-php-text-template4.spec b/php-phpunit-php-text-template4.spec
index e00b883..0294d4a 100644
--- a/php-phpunit-php-text-template4.spec
+++ b/php-phpunit-php-text-template4.spec
@@ -1,18 +1,19 @@
-# remirepo/fedora spec file for php-phpunit-php-text-template3
+# remirepo/fedora spec file for php-phpunit-php-text-template4
#
-# Copyright (c) 2010-2023 Remi Collet
+# Copyright (c) 2010-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%bcond_without tests
+%bcond_with tests
-%global gh_commit 0c7b06ff49e3d5072f057eb1fa59258bf287a748
+%global gh_commit d38f6cbff1cdb6f40b03c9811421561668cc133e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-text-template
+%global gh_date 2024-02-02
# Packagist
%global pk_vendor phpunit
%global pk_project %{gh_project}
@@ -20,10 +21,10 @@
%global ns_vendor SebastianBergmann
%global ns_project Template
%global php_home %{_datadir}/php
-%global ver_major 3
+%global ver_major 4
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 3.0.1
+Version: 4.0.0
Release: 1%{?dist}
Summary: Simple template engine, version %{ver_major}
@@ -33,18 +34,18 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.1
+BuildRequires: php(language) >= 8.2
BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json, require-dev
-# "phpunit/phpunit": "^10.0"
-BuildRequires: phpunit10
+# "phpunit/phpunit": "^11.0"
+BuildRequires: phpunit11
%endif
# From composer.json
-# "php": ">=8.1"
-Requires: php(language) >= 8.1
+# "php": ">=8.2"
+Requires: php(language) >= 8.2
# From phpcompatinfo report for version 3.0.0
Requires: php-spl
@@ -102,6 +103,12 @@ exit $ret
%changelog
+* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- update to 4.0.0
+- raise dependency on PHP 8.2
+- rename to php-phpunit-php-text-template4
+- move to /usr/share/php/SebastianBergmann/Template4
+
* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 3.0.1-1
- update to 3.0.1