summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-text-template3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-text-template3.spec')
-rw-r--r--php-phpunit-php-text-template3.spec48
1 files changed, 26 insertions, 22 deletions
diff --git a/php-phpunit-php-text-template3.spec b/php-phpunit-php-text-template3.spec
index 74996c0..6043e08 100644
--- a/php-phpunit-php-text-template3.spec
+++ b/php-phpunit-php-text-template3.spec
@@ -1,13 +1,16 @@
-# remirepo/fedora spec file for php-phpunit-php-text-template2
+# remirepo/fedora spec file for php-phpunit-php-text-template3
#
-# Copyright (c) 2010-2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2010-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
-%global gh_commit 5da5f67fc95621df9ff4c4e5a84d6a8a2acf7c28
+
+# disabled until phpunit10 available
+%bcond_with tests
+
+%global gh_commit 9f3d3709577a527025f55bcf0f7ab8052c8bb37d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-text-template
@@ -18,16 +21,10 @@
%global ns_vendor SebastianBergmann
%global ns_project Template
%global php_home %{_datadir}/php
-%global ver_major 2
-
-%if %{bootstrap}
-%bcond_with tests
-%else
-%bcond_without tests
-%endif
+%global ver_major 3
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 2.0.4
+Version: 3.0.0
Release: 1%{?dist}
Summary: Simple template engine, version %{ver_major}
@@ -37,26 +34,27 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.1
+BuildRequires: php-spl
BuildRequires: php-cli
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# From composer.json, require-dev
-# "phpunit/phpunit": "^9.3"
-BuildRequires: phpunit9 >= 9.3
+# "phpunit/phpunit": "^10.0"
+BuildRequires: phpunit10
%endif
# From composer.json
-# "php": ">=7.3"
-Requires: php(language) >= 7.3
-# From phpcompatinfo report for version 2.0.0
+# "php": ">=8.1"
+Requires: php(language) >= 8.1
+# From phpcompatinfo report for version 3.0.0
Requires: php-spl
Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
%description
-Simple template engine.
+Simple template engine, version %{ver_major}.
%prep
@@ -81,10 +79,10 @@ mkdir vendor
: Run upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php \
- %{_bindir}/phpunit9 --verbose || ret=1
+ %{_bindir}/phpunit10 --verbose || ret=1
fi
done
exit $ret
@@ -102,6 +100,12 @@ exit $ret
%changelog
+* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- raise dependency on PHP 8.1
+- rename to php-phpunit-php-text-template3
+- move to /usr/share/php/SebastianBergmann/Template3
+
* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 2.0.4-1
- update to 2.0.4