summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-phpunit-php-text-template2.spec17
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 0955bab..dc57650 100644
--- a/composer.json
+++ b/composer.json
@@ -25,7 +25,7 @@
"sort-packages": true
},
"require": {
- "php": "^7.3"
+ "php": "^7.3 || ^8.0"
},
"require-dev": {
"phpunit/phpunit": "^9.0"
diff --git a/php-phpunit-php-text-template2.spec b/php-phpunit-php-text-template2.spec
index fbc80d0..7d6f2c9 100644
--- a/php-phpunit-php-text-template2.spec
+++ b/php-phpunit-php-text-template2.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 0c69cbf965d5317ba33f24a352539f354a25db09
+%global gh_commit 6ff9c8ea4d3212b88fcf74e25e516e2c51c99324
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-text-template
@@ -21,13 +21,13 @@
%global ver_major 2
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?dist}
Summary: Simple template engine
@@ -40,14 +40,14 @@ BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-cli
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# From composer.json, require-dev
# "phpunit/phpunit": "^9.0"
BuildRequires: phpunit9
%endif
# From composer.json
-# "php": "^7.3"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# From phpcompatinfo report for version 2.0.0
Requires: php-spl
@@ -73,7 +73,7 @@ mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}
-%if %{with_tests}
+%if %{with tests}
%check
: Generate tests autoloader
mkdir vendor
@@ -102,6 +102,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- update to 2.0.2
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
- update to 2.0.1
- sources from git snapshot