summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-16 07:27:28 +0200
committerRemi Collet <remi@remirepo.net>2020-06-16 07:27:28 +0200
commit238f4f720a972c752faf7f88c9038a61b19469c2 (patch)
tree82930a03da5b03676072844c68ed04b2b8f7cc47
parentc9c5d19ccc8598c6e36431560e8c7dad578206a3 (diff)
update to 3.0.1
sources from git snapshot
-rw-r--r--php-phpunit-php-invoker3.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/php-phpunit-php-invoker3.spec b/php-phpunit-php-invoker3.spec
index 1753322..0c81072 100644
--- a/php-phpunit-php-invoker3.spec
+++ b/php-phpunit-php-invoker3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7579d5a1ba7f3ac11c80004d205877911315ae7a
+%global gh_commit 62f696ad0d140e0e513e69eaafdebb674d622b4c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-invoker
@@ -27,13 +27,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.0
+Version: 3.0.1
Release: 1%{?dist}
Summary: Invoke callables with a timeout
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
@@ -43,8 +44,7 @@ BuildRequires: php-fedora-autoloader-devel
# "ext-pcntl": "*"
# "phpunit/phpunit": "^9.0"
BuildRequires: php-pcntl
-# TODO test suite passes with v8, switch to v9 when available
-BuildRequires: phpunit8
+BuildRequires: phpunit9
%endif
# From composer.json, require
@@ -89,10 +89,10 @@ mkdir vendor
: Run upstream test suite
ret=0
-for cmd in php php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit8 --verbose || ret=1
+ %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -110,6 +110,10 @@ exit $ret
%changelog
+* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1
+- sources from git snapshot
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
- raise dependency on PHP 7.3