summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-30 10:42:28 +0100
committerRemi Collet <remi@remirepo.net>2020-11-30 10:42:28 +0100
commitbb1564df8447172aed4bc1482af24dc2d1fb1cb0 (patch)
tree6d924789cfac495a4070af38558689446c02d473
parent4cb460f06ef7c50e976069513e56d5699fe803a8 (diff)
update to 2.0.1 (no change)
switch to phpunit8
-rw-r--r--composer.json4
-rw-r--r--php-phpunit-php-invoker2.spec21
2 files changed, 14 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 46b6ef3..9db787f 100644
--- a/composer.json
+++ b/composer.json
@@ -23,11 +23,11 @@
"sort-packages": true
},
"require": {
- "php": "^7.1",
+ "php": ">=7.1",
"ext-pcntl": "*"
},
"require-dev": {
- "phpunit/phpunit": "^6.5"
+ "phpunit/phpunit": "^8.5"
},
"autoload": {
"classmap": [
diff --git a/php-phpunit-php-invoker2.spec b/php-phpunit-php-invoker2.spec
index 235bdf7..d8124a7 100644
--- a/php-phpunit-php-invoker2.spec
+++ b/php-phpunit-php-invoker2.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 4a01883f660b10d4a19a14de5efd19b22eac2d93
+%global gh_commit 9ee24c724374ba355385e98808da8b4343b28f67
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-invoker
@@ -21,26 +21,25 @@
%endif
Name: php-phpunit-php-invoker2
-Version: 2.0.0
+Version: 2.0.1
Release: 1%{?dist}
Summary: Invoke callables with a timeout
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
BuildArch: noarch
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.2
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# From composer.json, require-dev
-# "phpunit/phpunit": "^6.5"
-BuildRequires: phpunit6 >= 6.5
+# "phpunit/phpunit": "^8.5"
+BuildRequires: phpunit8 >= 8.5
%endif
# From composer.json, require
-# "php": "^7.1",
+# "php": ">=7.1",
# "ext-pcntl": "*"
Requires: php(language) >= 7.1
Requires: php-pcntl
@@ -82,10 +81,10 @@ mkdir vendor
: Run upstream test suite
ret=0
-for cmd in php php71 php72; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php \
- %{_bindir}/phpunit6 --verbose || ret=1
+ %{_bindir}/phpunit8 --verbose || ret=1
fi
done
exit $ret
@@ -102,6 +101,10 @@ exit $ret
%changelog
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1 (no change)
+- switch to phpunit8
+
* Mon Jan 29 2018 Remi Collet <remi@remirepo.net> - 2.0.0-1
- Update to 2.0.0
- rename to php-phpunit-php-invoker2