summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-file-iterator5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-file-iterator5.spec')
-rw-r--r--php-phpunit-php-file-iterator5.spec20
1 files changed, 13 insertions, 7 deletions
diff --git a/php-phpunit-php-file-iterator5.spec b/php-phpunit-php-file-iterator5.spec
index 5e93ebe..00146b8 100644
--- a/php-phpunit-php-file-iterator5.spec
+++ b/php-phpunit-php-file-iterator5.spec
@@ -8,13 +8,14 @@
# Please, preserve the changelog entries
#
+# disabled until phpunit11 available
%bcond_with tests
-%global gh_commit 99e95c94ad9500daca992354fa09d7b99abe2210
+%global gh_commit 118cfaaa8bc5aef3287bf315b6060b1174754af6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-file-iterator
-%global gh_date 2024-02-02
+%global gh_date 2024-08-27
%global php_home %{_datadir}/php
# Packagist
%global pk_vendor phpunit
@@ -26,12 +27,13 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 5.0.0
+Version: 5.1.0
Release: 1%{?dist}
Summary: FilterIterator implementation based on a list of suffixes, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
+# run makesrc.sh to create a git snapshot with test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -89,10 +91,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php81 php82 php83; do
+for cmd in php php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit10 || ret=1
+ %{_bindir}/phpunit11 || ret=1
fi
done
exit $ret
@@ -102,8 +104,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc ChangeLog.md README.md composer.json
%dir %{php_home}/%{ns_vendor}
@@ -111,6 +111,12 @@ exit $ret
%changelog
+* Tue Aug 27 2024 Remi Collet <remi@remirepo.net> - 5.1.0-1
+- update to 5.1.0
+
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 5.0.1-1
+- update to 5.0.1
+
* Mon Feb 5 2024 Remi Collet <remi@remirepo.net> - 5.0.0-1
- update to 5.0.0
- raise dependency on PHP 8.2