summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-28 09:31:17 +0200
committerRemi Collet <remi@remirepo.net>2020-09-28 09:31:17 +0200
commitf22fd8cd894fda143774092e53eae2679e9a614c (patch)
tree962703d89e533057e2b31d82850e85e332750f1b
parentd27e17d727673e04f4e80492551bb64459628f3d (diff)
update to 3.0.5 (no change)
-rw-r--r--composer.json4
-rw-r--r--php-phpunit-php-file-iterator3.spec13
2 files changed, 10 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index fe4c923..f1b95b3 100644
--- a/composer.json
+++ b/composer.json
@@ -27,10 +27,10 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3 || ^8.0"
+ "php": ">=7.3"
},
"require-dev": {
- "phpunit/phpunit": "^9.0"
+ "phpunit/phpunit": "^9.3"
},
"autoload": {
"classmap": [
diff --git a/php-phpunit-php-file-iterator3.spec b/php-phpunit-php-file-iterator3.spec
index 4f0d4d8..9eaa739 100644
--- a/php-phpunit-php-file-iterator3.spec
+++ b/php-phpunit-php-file-iterator3.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 25fefc5b19835ca653877fe081644a3f8c1d915e
+%global gh_commit aa4be8575f26070b100fccb67faabb28f21f66f8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-file-iterator
@@ -28,7 +28,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.4
+Version: 3.0.5
Release: 1%{?dist}
Summary: FilterIterator implementation that filters files based on a list of suffixes
@@ -40,8 +40,8 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with tests}
# From composer.json, "require-dev"
-# "phpunit/phpunit": "^9.0"
-BuildRequires: phpunit9
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
BuildRequires: php(language) >= 7.3
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -49,7 +49,7 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require"
-# "php": "^7.3 || ^8.0"
+# "php": ">=7.3"
Requires: php(language) >= 7.3
# From phpcompatinfo report for 3.0.0
Requires: php-pcre
@@ -109,6 +109,9 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 3.0.5-1
+- update to 3.0.5 (no change)
+
* Mon Jul 13 2020 Remi Collet <remi@remirepo.net> - 3.0.4-1
- update to 3.0.4