summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-29 07:37:37 +0200
committerRemi Collet <remi@remirepo.net>2020-06-29 07:37:37 +0200
commitc133031771b225b24566050a3ba4e7249a0b85ad (patch)
tree13789b856cd36a8c2924ed40f39d19da9aa8301a
parent265637b692138d279d1d72be5bc857c368b761ea (diff)
update to 3.0.3HEADmaster
-rw-r--r--composer.json2
-rw-r--r--php-phpunit-php-file-iterator3.spec15
2 files changed, 10 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 4a6e6f8..fe4c923 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,7 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3"
+ "php": "^7.3 || ^8.0"
},
"require-dev": {
"phpunit/phpunit": "^9.0"
diff --git a/php-phpunit-php-file-iterator3.spec b/php-phpunit-php-file-iterator3.spec
index 74f2314..21cd688 100644
--- a/php-phpunit-php-file-iterator3.spec
+++ b/php-phpunit-php-file-iterator3.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit eba15e538f2bb3fe018b7bbb47d2fe32d404bfd2
+%global gh_commit 8e282e5f5e2db5fb2271b3962ad69875c34a6f41
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-file-iterator
@@ -21,14 +21,14 @@
%global ns_vendor SebastianBergmann
%global ns_project FileIterator
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.2
+Version: 3.0.3
Release: 1%{?dist}
Summary: FilterIterator implementation that filters files based on a list of suffixes
@@ -38,7 +38,7 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# From composer.json, "require-dev"
# "phpunit/phpunit": "^9.0"
BuildRequires: phpunit9
@@ -49,7 +49,7 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require"
-# "php": "^7.3"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# From phpcompatinfo report for 3.0.0
Requires: php-pcre
@@ -109,6 +109,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 3.0.3-1
+- update to 3.0.3
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 3.0.2-1
- update to 3.0.2
- sources from git snapshot