summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-30 10:39:20 +0100
committerRemi Collet <remi@remirepo.net>2020-11-30 10:39:20 +0100
commit88863ebb947ccc8f91d6be083c0116ad3f5c7fb4 (patch)
tree0a2abdd6620922649279217e67575b238953a343
parent70b4a5d98ea0d546e91be1b45809f41dbabdcdd8 (diff)
update to 2.0.3 (no change)
switch to phpunit8
-rw-r--r--composer.json4
-rw-r--r--php-phpunit-php-file-iterator2.spec18
2 files changed, 13 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 002e511..b1717b8 100644
--- a/composer.json
+++ b/composer.json
@@ -19,10 +19,10 @@
"issues": "https://github.com/sebastianbergmann/php-file-iterator/issues"
},
"require": {
- "php": "^7.1"
+ "php": ">=7.1"
},
"require-dev": {
- "phpunit/phpunit": "^7.1"
+ "phpunit/phpunit": "^8.5"
},
"autoload": {
"classmap": [
diff --git a/php-phpunit-php-file-iterator2.spec b/php-phpunit-php-file-iterator2.spec
index fe82712..26e82c1 100644
--- a/php-phpunit-php-file-iterator2.spec
+++ b/php-phpunit-php-file-iterator2.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 050bedf145a257b1ff02746c31894800e5122946
+%global gh_commit 4b49fb70f067272b659ef0174ff9ca40fdaa6357
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-file-iterator
@@ -28,7 +28,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.2
+Version: 2.0.3
Release: 1%{?dist}
Summary: FilterIterator implementation that filters files based on a list of suffixes
@@ -39,9 +39,9 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# From composer.json, "require-dev"
-# "phpunit/phpunit": "^7.1"
-BuildRequires: phpunit7 >= 7.1
-BuildRequires: php(language) >= 7.1
+# "phpunit/phpunit": "^8.5"
+BuildRequires: phpunit8 >= 8.5
+BuildRequires: php(language) >= 7.2
BuildRequires: php-pcre
BuildRequires: php-spl
%endif
@@ -86,10 +86,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php71 php72; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit7 --verbose || ret=1
+ %{_bindir}/phpunit8 --verbose || ret=1
fi
done
exit $ret
@@ -108,6 +108,10 @@ exit $ret
%changelog
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 2.0.3-1
+- update to 2.0.3 (no change)
+- switch to phpunit8
+
* Fri Sep 14 2018 Remi Collet <remi@remirepo.net> - 2.0.2-1
- update to 2.0.2
- run upstream test suite