summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-29 08:50:56 +0200
committerRemi Collet <remi@remirepo.net>2021-03-29 08:50:56 +0200
commit780b521bbe15a5b56bc72a56b93ce2c7b5432f65 (patch)
treed6a994be8cf6f7cddc76b98dd479caf7401ae26d
parent5bcb2c05adcc89d89660161d58ea181d197d9ddc (diff)
update to 9.2.6HEADmaster
-rw-r--r--composer.json2
-rw-r--r--php-phpunit-php-code-coverage9.spec21
2 files changed, 15 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 78e0593..fbc1081 100644
--- a/composer.json
+++ b/composer.json
@@ -38,7 +38,7 @@
"sebastian/code-unit-reverse-lookup": "^2.0.2",
"sebastian/complexity": "^2.0",
"sebastian/environment": "^5.1.2",
- "sebastian/lines-of-code": "^1.0",
+ "sebastian/lines-of-code": "^1.0.3",
"sebastian/version": "^3.0.1",
"theseer/tokenizer": "^1.2.0"
},
diff --git a/php-phpunit-php-code-coverage9.spec b/php-phpunit-php-code-coverage9.spec
index 89e66fb..9347d90 100644
--- a/php-phpunit-php-code-coverage9.spec
+++ b/php-phpunit-php-code-coverage9.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 0a7f0acf9269c190fd982b5c04423feae986b6e0
+%global gh_commit f6293e1b30a2354e8428e004689671b83871edde
#global gh_date 20150924
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -25,7 +25,7 @@
%global ver_major 9
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 9.2.4
+Version: 9.2.6
Release: 1%{?dist}
Summary: PHP code coverage information
@@ -50,7 +50,7 @@ BuildRequires: (php-composer(phpunit/php-text-template) >= 2.0.2 with
BuildRequires: (php-composer(sebastian/code-unit-reverse-lookup) >= 2.0.2 with php-composer(sebastian/code-unit-reverse-lookup) < 3)
BuildRequires: (php-composer(sebastian/complexity) >= 2.0 with php-composer(sebastian/complexity) < 3)
BuildRequires: (php-composer(sebastian/environment) >= 5.1.2 with php-composer(sebastian/environment) < 6)
-BuildRequires: (php-composer(sebastian/lines-of-code) >= 1.0 with php-composer(sebastian/lines-of-code) < 2)
+BuildRequires: (php-composer(sebastian/lines-of-code) >= 1.0.3 with php-composer(sebastian/lines-of-code) < 2)
BuildRequires: (php-composer(sebastian/version) >= 3.0.1 with php-composer(sebastian/version) < 4)
BuildRequires: (php-composer(theseer/tokenizer) >= 1.2.0 with php-composer(theseer/tokenizer) < 2)
# remirepo:11
@@ -61,7 +61,7 @@ BuildRequires: php-phpunit-php-text-template2 >= 2.0.2
BuildRequires: php-sebastian-code-unit-reverse-lookup2 >= 2.0.2
BuildRequires: php-sebastian-complexity >= 2.0.0
BuildRequires: php-sebastian-environment5 >= 5.1.2
-BuildRequires: php-sebastian-lines-of-code >= 1.0
+BuildRequires: php-sebastian-lines-of-code >= 1.0.3
BuildRequires: php-sebastian-version3 >= 3.0.1
BuildRequires: php-theseer-tokenizer >= 1.2.0
%endif
@@ -82,7 +82,7 @@ BuildRequires: php-xdebug
# "sebastian/code-unit-reverse-lookup": "^2.0.2",
# "sebastian/complexity": "^2.0",
# "sebastian/environment": "^5.1.2",
-# "sebastian/lines-of-code": "^1.0",
+# "sebastian/lines-of-code": "^1.0.3",
# "sebastian/version": "^3.0.1",
# "theseer/tokenizer": "^1.2.0"
Requires: php(language) >= 7.3
@@ -97,7 +97,7 @@ Requires: (php-composer(phpunit/php-text-template) >= 2.0.2 with
Requires: (php-composer(sebastian/code-unit-reverse-lookup) >= 2.0.2 with php-composer(sebastian/code-unit-reverse-lookup) < 3)
Requires: (php-composer(sebastian/complexity) >= 2.0 with php-composer(sebastian/complexity) < 3)
Requires: (php-composer(sebastian/environment) >= 5.1.2 with php-composer(sebastian/environment) < 6)
-Requires: (php-composer(sebastian/lines-of-code) >= 1.0 with php-composer(sebastian/lines-of-code) < 2)
+Requires: (php-composer(sebastian/lines-of-code) >= 1.0.3 with php-composer(sebastian/lines-of-code) < 2)
Requires: (php-composer(sebastian/version) >= 3.0.1 with php-composer(sebastian/version) < 4)
Requires: (php-composer(theseer/tokenizer) >= 1.2.0 with php-composer(theseer/tokenizer) < 2)
# From composer.json, suggest
@@ -113,7 +113,7 @@ Requires: php-phpunit-php-text-template2 >= 2.0.2
Requires: php-sebastian-code-unit-reverse-lookup2 >= 2.0.2
Requires: php-sebastian-complexity >= 2.0.0
Requires: php-sebastian-environment5 >= 5.1.2
-Requires: php-sebastian-lines-of-code >= 1.0
+Requires: php-sebastian-lines-of-code >= 1.0.3
Requires: php-sebastian-version3 >= 3.0.1
Requires: php-theseer-tokenizer >= 1.2.0
%endif
@@ -213,6 +213,13 @@ exit $ret
%changelog
+* Mon Mar 29 2021 Remi Collet <remi@remirepo.net> - 9.2.6-1
+- update to 9.2.6
+
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 9.2.5-1
+- update to 9.2.5
+- raise dependency on sebastian/lines-of-code 1.0.3
+
* Fri Nov 27 2020 Remi Collet <remi@remirepo.net> - 9.2.4-1
- update to 9.2.4