summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-phpunit-php-code-coverage8.spec13
2 files changed, 37 insertions, 4 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..8152336
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_vendor/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-phpunit-php-code-coverage8.spec b/php-phpunit-php-code-coverage8.spec
index 0247cf0..2b2b960 100644
--- a/php-phpunit-php-code-coverage8.spec
+++ b/php-phpunit-php-code-coverage8.spec
@@ -9,7 +9,7 @@
%global bootstrap 0
# Github
-%global gh_commit 31e94ccc084025d6abee0585df533eb3a792b96a
+%global gh_commit ca6647ffddd2add025ab3f21644a441d7c146cdc
#global gh_date 20150924
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -29,7 +29,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 8.0.1
+Version: 8.0.2
Release: 1%{?dist}
Summary: PHP code coverage information
@@ -39,7 +39,8 @@ Summary: PHP code coverage information
# ASL 2.0: nvd3
License: BSD and MIT and ASL 2.0
URL: https://github.com/%{gh_vendor}/%{gh_project}
-Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
@@ -178,7 +179,7 @@ define('TEST_FILES_PATH', __DIR__ . '/_files/');
EOF
ret=0
-for cmd in php php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd $EXT \
-d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php \
@@ -201,6 +202,10 @@ exit $ret
%changelog
+* Sun May 24 2020 Remi Collet <remi@remirepo.net> - 8.0.2-1
+- update to 8.0.2
+- sources from git snapshot
+
* Wed Feb 19 2020 Remi Collet <remi@remirepo.net> - 8.0.1-1
- update to 8.0.1