summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-08 10:12:14 +0200
committerRemi Collet <remi@remirepo.net>2019-07-08 10:12:14 +0200
commit1f96f4db4612e28fc06cc317e4a5074319314907 (patch)
treef79545de86319c22d9b9f9f20051fa9bd71b2b0c
parentcef39ff3802f2306ff8a29d8909ba56a5b7e0f71 (diff)
- update to 7.0.6HEADmaster
- raise dependency on phpunit/php-token-stream 3.0.2 - raise dependency on sebastian/environment 4.2.2 - raise dependency on theseer/tokenizer 1.1.3
-rw-r--r--composer.json10
-rw-r--r--php-phpunit-php-code-coverage7.spec44
2 files changed, 30 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 6bfb0a2..8e9ac88 100644
--- a/composer.json
+++ b/composer.json
@@ -29,18 +29,18 @@
"ext-dom": "*",
"ext-xmlwriter": "*",
"phpunit/php-file-iterator": "^2.0.2",
- "phpunit/php-token-stream": "^3.0.1",
+ "phpunit/php-token-stream": "^3.0.2",
"phpunit/php-text-template": "^1.2.1",
"sebastian/code-unit-reverse-lookup": "^1.0.1",
- "sebastian/environment": "^4.1",
+ "sebastian/environment": "^4.2.2",
"sebastian/version": "^2.0.1",
- "theseer/tokenizer": "^1.1"
+ "theseer/tokenizer": "^1.1.3"
},
"require-dev": {
- "phpunit/phpunit": "^8.0"
+ "phpunit/phpunit": "^8.2.2"
},
"suggest": {
- "ext-xdebug": "^2.6.1"
+ "ext-xdebug": "^2.7.2"
},
"autoload": {
"classmap": [
diff --git a/php-phpunit-php-code-coverage7.spec b/php-phpunit-php-code-coverage7.spec
index 53f7cae..91b68d5 100644
--- a/php-phpunit-php-code-coverage7.spec
+++ b/php-phpunit-php-code-coverage7.spec
@@ -9,7 +9,7 @@
%global bootstrap 0
# Github
-%global gh_commit aed67b57d459dcab93e84a5c9703d3deb5025dff
+%global gh_commit d471d0d2b529a67c6a722dd446c4ec90881ac315
#global gh_date 20150924
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -29,7 +29,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 7.0.5
+Version: 7.0.6
Release: 1%{?dist}
Summary: PHP code coverage information
@@ -48,26 +48,26 @@ BuildRequires: php(language) >= 7.2
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpunit/php-file-iterator) >= 2.0.2 with php-composer(phpunit/php-file-iterator) < 3)
-BuildRequires: (php-composer(phpunit/php-token-stream) >= 3.0.1 with php-composer(phpunit/php-token-stream) < 4)
+BuildRequires: (php-composer(phpunit/php-token-stream) >= 3.0.2 with php-composer(phpunit/php-token-stream) < 4)
BuildRequires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
BuildRequires: (php-composer(sebastian/code-unit-reverse-lookup) >= 1.0.1 with php-composer(sebastian/code-unit-reverse-lookup) < 2)
-BuildRequires: (php-composer(sebastian/environment) >= 4.1 with php-composer(sebastian/environment) < 5)
+BuildRequires: (php-composer(sebastian/environment) >= 4.2.2 with php-composer(sebastian/environment) < 5)
BuildRequires: (php-composer(sebastian/version) >= 2.0.1 with php-composer(sebastian/version) < 3)
-BuildRequires: (php-composer(theseer/tokenizer) >= 1.1 with php-composer(theseer/tokenizer) < 2)
+BuildRequires: (php-composer(theseer/tokenizer) >= 1.1.3 with php-composer(theseer/tokenizer) < 2)
# remirepo:9
%else
BuildRequires: php-phpunit-php-file-iterator2 >= 2.0.2
-BuildRequires: php-phpunit-php-token-stream3 >= 3.0.1
+BuildRequires: php-phpunit-php-token-stream3 >= 3.0.2
BuildRequires: php-phpunit-Text-Template >= 1.2.1
BuildRequires: php-sebastian-code-unit-reverse-lookup >= 1.0.1
-BuildRequires: php-sebastian-environment4 >= 4.1
+BuildRequires: php-sebastian-environment4 >= 4.2.2
BuildRequires: php-phpunit-Version >= 2.0.1
-BuildRequires: php-theseer-tokenizer >= 1.1
+BuildRequires: php-theseer-tokenizer >= 1.1.3
%endif
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^8.0"
+# "phpunit/phpunit": "^8.2.2"
# 7.2 because of tests
-BuildRequires: phpunit8
+BuildRequires: phpunit8 >= 8.2.2
BuildRequires: php-pecl-xdebug >= 2.6.1
%endif
@@ -76,24 +76,24 @@ BuildRequires: php-pecl-xdebug >= 2.6.1
# "ext-dom": "*",
# "ext-xmlwriter": "*",
# "phpunit/php-file-iterator": "^2.0.2",
-# "phpunit/php-token-stream": "^3.0.1",
+# "phpunit/php-token-stream": "^3.0.2",
# "phpunit/php-text-template": "^1.2.1",
# "sebastian/code-unit-reverse-lookup": "^1.0.1",
-# "sebastian/environment": "^4.1",
+# "sebastian/environment": "^4.2.2",
# "sebastian/version": "^2.0.1",
-# "theseer/tokenizer": "^1.1"
+# "theseer/tokenizer": "^1.1.3"
Requires: php(language) >= 7.1
Requires: php-dom
Requires: php-xmlwriter
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpunit/php-file-iterator) >= 2.0.2 with php-composer(phpunit/php-file-iterator) < 3)
-Requires: (php-composer(phpunit/php-token-stream) >= 3.0.1 with php-composer(phpunit/php-token-stream) < 4)
+Requires: (php-composer(phpunit/php-token-stream) >= 3.0.2 with php-composer(phpunit/php-token-stream) < 4)
Requires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
Requires: (php-composer(sebastian/code-unit-reverse-lookup) >= 1.0.1 with php-composer(sebastian/code-unit-reverse-lookup) < 2)
-Requires: (php-composer(sebastian/environment) >= 4.1 with php-composer(sebastian/environment) < 5)
+Requires: (php-composer(sebastian/environment) >= 4.2.2 with php-composer(sebastian/environment) < 5)
Requires: (php-composer(sebastian/version) >= 2.0.1 with php-composer(sebastian/version) < 3)
-Requires: (php-composer(theseer/tokenizer) >= 1.1 with php-composer(theseer/tokenizer) < 2)
+Requires: (php-composer(theseer/tokenizer) >= 1.1.3 with php-composer(theseer/tokenizer) < 2)
# From composer.json, suggest
# "ext-xdebug": ">=2.6.1",
Suggests: php-xdebug
@@ -101,12 +101,12 @@ Suggests: php-pcov
# remirepo:9
%else
Requires: php-phpunit-php-file-iterator2 >= 2.0.2
-Requires: php-phpunit-php-token-stream3 >= 3.0.1
+Requires: php-phpunit-php-token-stream3 >= 3.0.2
Requires: php-phpunit-Text-Template >= 1.2.1
Requires: php-sebastian-code-unit-reverse-lookup >= 1.0.1
-Requires: php-sebastian-environment4 >= 4.1
+Requires: php-sebastian-environment4 >= 4.2.2
Requires: php-phpunit-Version >= 2.0.1
-Requires: php-theseer-tokenizer >= 1.1
+Requires: php-theseer-tokenizer >= 1.1.3
%endif
# From phpcompatinfo report for version 5.0.0
Requires: php-reflection
@@ -202,6 +202,12 @@ exit $ret
%changelog
+* Mon Jul 8 2019 Remi Collet <remi@remirepo.net> - 7.0.6-1
+- update to 7.0.6
+- raise dependency on phpunit/php-token-stream 3.0.2
+- raise dependency on sebastian/environment 4.2.2
+- raise dependency on theseer/tokenizer 1.1.3
+
* Thu Jun 6 2019 Remi Collet <remi@remirepo.net> - 7.0.5-1
- update to 7.0.5